summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Mariański2022-10-02 12:10:33 +0200
committerŁukasz Mariański2022-10-02 12:10:33 +0200
commit9fc6fd228d8596c8080f1553d6055d65683413ad (patch)
tree57c8ae704cb9ffc901ff1b722b24e073c48342a9
parentd82aa1381038fd88a50ab3a031cb6796db9447c8 (diff)
downloadaur-9fc6fd228d8596c8080f1553d6055d65683413ad.tar.gz
remove updater.win32.js require
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--replugged.patch12
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 717898eb3461..c24e91eb533e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = replugged-electron-git
pkgdesc = A fork of Powercord, the lightweight discord client mod focused on simplicity and performance.
- pkgver = r1686.38b0c9ff
- pkgrel = 2
+ pkgver = r1784.e984d8fd
+ pkgrel = 1
url = https://github.com/replugged-org/replugged
install = replugged.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index ce96d21e8a8c..e19bff9bb7d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Łukasz Mariański <lmarianski at protonmail dot com>
pkgname=replugged-electron-git
_pkgname="${pkgname%-electron-*}"
-pkgver=r1686.38b0c9ff
-pkgrel=2
+pkgver=r1784.e984d8fd
+pkgrel=1
pkgdesc="A fork of Powercord, the lightweight discord client mod focused on simplicity and performance."
arch=('any')
url="https://github.com/${_pkgname}-org/${_pkgname}"
diff --git a/replugged.patch b/replugged.patch
index 5fe6c7a7c498..a242ab6879a6 100644
--- a/replugged.patch
+++ b/replugged.patch
@@ -143,7 +143,7 @@ index 770e195a..e542774c 100644
}
diff --git a/src/Powercord/index.js b/src/Powercord/index.js
-index 1ff93b59..2a0d9529 100644
+index 019e304c..0de3d47e 100644
--- a/src/Powercord/index.js
+++ b/src/Powercord/index.js
@@ -253,6 +253,32 @@ class Powercord extends Updatable {
@@ -256,7 +256,7 @@ index 147e02e9..948f2b02 100644
// Discord Server
DISCORD_INVITE: 'B2TcnXV9Rg',
diff --git a/src/patcher.js b/src/patcher.js
-index 372e41f5..a8d59761 100644
+index 372e41f5..eaace1cf 100644
--- a/src/patcher.js
+++ b/src/patcher.js
@@ -7,7 +7,7 @@ const { existsSync, unlinkSync } = require('fs');
@@ -268,3 +268,11 @@ index 372e41f5..a8d59761 100644
require.main.filename = join(discordPath, 'app_bootstrap/index.js');
const electron = require('electron');
+@@ -30,7 +30,6 @@ function setAppUserModelId (...args) {
+ appSetAppUserModelId.apply(this, args);
+ if (!_patched) {
+ _patched = true;
+- require('./updater.win32');
+ }
+ }
+