summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbenklett2015-06-08 14:54:35 +0200
committerbenklett2015-06-08 15:00:47 +0200
commit4f5d690ea46a963836d022e815d0ef056c2e27ed (patch)
treebe7d1023786cad967cd85b815e4cd6f63d277c88
downloadaur-4f5d690ea46a963836d022e815d0ef056c2e27ed.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD34
-rw-r--r--python2-patch.diff8
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4d85f25377e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = repo
+ pkgdesc = The Multiple Git Repository Tool from the Android Open Source Project
+ pkgver = 1.21
+ pkgrel = 5
+ url = http://source.android.com/source/git-repo.html
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ depends = git
+ depends = python2
+ source = git+https://android.googlesource.com/tools/repo.git#tag=v1.12.22
+ source = python2-patch.diff
+ sha256sums = SKIP
+ sha256sums = 26867df82596df8335af4b5710a97c95322439da955ec6cddbea781e44c88f0d
+
+pkgname = repo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2b5af6607797
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar
+*.tar.*
+*.txt
+
+src/*
+pkg/*
+repo/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01e8d0d5726a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+## Maintainer: benklett <b.klettbach@gmail.com>
+
+pkgname=repo
+# pkgver from https://android.googlesource.com/tools/repo/+/v1.12.20/repo
+pkgver=1.21
+_tag=v1.12.22
+pkgrel=5
+pkgdesc="The Multiple Git Repository Tool from the Android Open Source Project"
+arch=("i686" "x86_64")
+url="http://source.android.com/source/git-repo.html"
+license=("APACHE")
+depends=("git" "python2")
+makedepends=("git")
+# source is always the current tag
+source=(
+ "git+https://android.googlesource.com/tools/repo.git#tag=${_tag}"
+ "python2-patch.diff"
+)
+sha256sums=(
+ "SKIP"
+ "26867df82596df8335af4b5710a97c95322439da955ec6cddbea781e44c88f0d"
+)
+
+build() {
+ cd ${pkgname}
+ # patching repo to use python2 instead of python3
+ patch -p1 < "${srcdir}/python2-patch.diff"
+}
+
+package() {
+ cd ${pkgname}
+ install -D -m 755 repo "${pkgdir}/usr/bin/repo"
+ install -D -m 644 docs/manifest-format.txt "${pkgdir}/usr/share/doc/${pkgname}/manifest-format.txt"
+}
diff --git a/python2-patch.diff b/python2-patch.diff
new file mode 100644
index 000000000000..d8bf4e1f6b49
--- /dev/null
+++ b/python2-patch.diff
@@ -0,0 +1,8 @@
+--- a/repo 2013-11-01 02:00:51.756586986 +0100
++++ b/repo 2013-11-01 02:01:03.465932479 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ ## repo default configuration
+ ##