summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2019-01-18 14:45:08 +0100
committerLuca Weiss2019-01-18 14:45:08 +0100
commit11218b4c08898e6b60a63586a56e7e1ee386b0a3 (patch)
treea1ab164289db447631aacf0bc766202fecb7ce6b
parent7e9c011f0c550bfd326926fb0446de63c352e069 (diff)
downloadaur-11218b4c08898e6b60a63586a56e7e1ee386b0a3.tar.gz
upgpkg: repo-git 1.13.2.r0.g13f323b2-1
Fix build for upstream changes and stylistic changes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD36
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72dd640372ff..50f3e8a39bf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = repo-git
- pkgdesc = Tool built on top of git to help manage many git repositories. Part of the Android project.
- pkgver = 1.12.26.r7.g5d0c3a6
+ pkgdesc = The Multiple Git Repository Tool
+ pkgver = 1.13.2.r0.g13f323b2
pkgrel = 1
url = https://source.android.com/source/developing.html
arch = any
- license = APACHE
+ license = Apache
depends = git
depends = python2
provides = repo
conflicts = repo
source = repo::git+https://gerrit.googlesource.com/git-repo
+ source = python2.patch
sha256sums = SKIP
+ sha256sums = bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4
pkgname = repo-git
diff --git a/PKGBUILD b/PKGBUILD
index 8407378ec98f..79b82535e0ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: Juston Li <juston.h.li@gmail.com>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contrubitor: Juston Li <juston.h.li@gmail.com>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
_pkgname=repo
-pkgname=$_pkgname-git
-pkgver=1.12.26.r7.g5d0c3a6
+pkgname=repo-git
+pkgver=1.13.2.r0.g13f323b2
pkgrel=1
-pkgdesc="Tool built on top of git to help manage many git repositories. Part of the Android project."
-arch=("any")
+pkgdesc="The Multiple Git Repository Tool"
+arch=('any')
url="https://source.android.com/source/developing.html"
-license=("APACHE")
-depends=("git" "python2")
+license=('Apache')
+depends=('git' 'python2')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo"
- "python2.patch")
-sha256sums=("SKIP"
- "bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4")
-
+ "python2.patch")
+sha256sums=('SKIP'
+ 'bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$_pkgname"
- patch -p1 < "${srcdir}/python2.patch"
+ cd "$_pkgname"
+ patch -Np1 -i "$srcdir"/python2.patch
}
package() {
- cd "$srcdir/$_pkgname"
- install -D -m 755 repo "$pkgdir/usr/bin/repo"
- install -D -m 644 docs/manifest-format.txt "$pkgdir/usr/share/doc/repo/manifest-format.txt"
+ cd "$_pkgname"
+ install -Dm755 repo "$pkgdir"/usr/bin/repo
+ install -Dm644 docs/manifest-format.md "$pkgdir"/usr/share/doc/repo/manifest-format.md
}