summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 23:46:16 +0200
committerJerome Leclanche2015-06-09 23:46:56 +0200
commit3fa2e590d24081b24fd2521c788906d89b428e0c (patch)
tree86b8a42439f96d32809736df8d70f20fcc294ace
parent5b819bd6dd7f930409b596f3c1f46d6fdcf10e11 (diff)
downloadaur-3fa2e590d24081b24fd2521c788906d89b428e0c.tar.gz
Remove patch for Python 2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--python2.patch10
3 files changed, 2 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a368a24cad7..82b703fe7f96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,9 +10,7 @@ pkgbase = repo-git
provides = repo
conflicts = repo
source = repo::git+https://gerrit.googlesource.com/git-repo
- source = python2.patch
sha256sums = SKIP
- sha256sums = 389cf97d9de0993838615691a6c9036ce91d0c659378de6d3b8310cdb15d764c
pkgname = repo-git
diff --git a/PKGBUILD b/PKGBUILD
index bb929b731540..207869cd8110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ license=("APACHE")
depends=("git" "python2")
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo" "python2.patch")
-sha256sums=("SKIP" "389cf97d9de0993838615691a6c9036ce91d0c659378de6d3b8310cdb15d764c")
+source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo")
+sha256sums=("SKIP")
pkgver() {
@@ -20,11 +20,6 @@ pkgver() {
echo $(git describe --always | sed "s/-/./g")
}
-prepare() {
- cd "$srcdir/$_pkgname"
- git apply "$srcdir/python2.patch"
-}
-
package() {
cd "$srcdir/$_pkgname"
install -D -m 755 repo "$pkgdir/usr/bin/repo"
diff --git a/python2.patch b/python2.patch
deleted file mode 100644
index 984404152ad6..000000000000
--- a/python2.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/repo b/repo
-index 58e82fe..9812d21 100755
---- a/repo
-+++ b/repo
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
-
- ## repo default configuration
- ##