summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 23:41:11 +0200
committerJerome Leclanche2015-06-09 23:41:11 +0200
commit5b819bd6dd7f930409b596f3c1f46d6fdcf10e11 (patch)
treeccc19b56ab5cc0aded46e7f4db0edde85a20631e
downloadaur-5b819bd6dd7f930409b596f3c1f46d6fdcf10e11.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--python2.patch10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a368a24cad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = repo-git
+ pkgdesc = Tool built on top of git to help manage many git repositories. Part of the Android project.
+ pkgver = v1.12.22.17.g185307d
+ pkgrel = 1
+ url = https://source.android.com/source/developing.html
+ arch = any
+ license = APACHE
+ depends = git
+ depends = python2
+ provides = repo
+ conflicts = repo
+ source = repo::git+https://gerrit.googlesource.com/git-repo
+ source = python2.patch
+ sha256sums = SKIP
+ sha256sums = 389cf97d9de0993838615691a6c9036ce91d0c659378de6d3b8310cdb15d764c
+
+pkgname = repo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb929b731540
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=repo
+pkgname=$_pkgname-git
+pkgver=v1.12.22.17.g185307d
+pkgrel=1
+pkgdesc="Tool built on top of git to help manage many git repositories. Part of the Android project."
+arch=("any")
+url="https://source.android.com/source/developing.html"
+license=("APACHE")
+depends=("git" "python2")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo" "python2.patch")
+sha256sums=("SKIP" "389cf97d9de0993838615691a6c9036ce91d0c659378de6d3b8310cdb15d764c")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo $(git describe --always | sed "s/-/./g")
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git apply "$srcdir/python2.patch"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m 755 repo "$pkgdir/usr/bin/repo"
+ install -D -m 644 docs/manifest-format.txt "$pkgdir/usr/share/doc/repo/manifest-format.txt"
+}
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..984404152ad6
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,10 @@
+diff --git a/repo b/repo
+index 58e82fe..9812d21 100755
+--- a/repo
++++ b/repo
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ ## repo default configuration
+ ##