summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2019-11-10 12:57:20 +0100
committerLuca Weiss2019-11-10 12:57:20 +0100
commit6b065c58f63972143136ebc92d4f0b0647adc8ca (patch)
treebaa91108af2012665de549bb0d63c7c1794801bc
parent11218b4c08898e6b60a63586a56e7e1ee386b0a3 (diff)
downloadaur-6b065c58f63972143136ebc92d4f0b0647adc8ca.tar.gz
upgpkg: repo-git 1.13.7.1.r0.gb466854b-1
python3 compatibility :)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 7 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50f3e8a39bf2..a3d1dc8ffe39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = repo-git
pkgdesc = The Multiple Git Repository Tool
- pkgver = 1.13.2.r0.g13f323b2
+ pkgver = 1.13.7.1.r0.gb466854b
pkgrel = 1
url = https://source.android.com/source/developing.html
arch = any
license = Apache
depends = git
- depends = python2
+ depends = python
provides = repo
conflicts = repo
source = repo::git+https://gerrit.googlesource.com/git-repo
- source = python2.patch
sha256sums = SKIP
- sha256sums = bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4
pkgname = repo-git
diff --git a/PKGBUILD b/PKGBUILD
index 79b82535e0ea..a6cdce1ae67e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,21 @@
_pkgname=repo
pkgname=repo-git
-pkgver=1.13.2.r0.g13f323b2
+pkgver=1.13.7.1.r0.gb466854b
pkgrel=1
pkgdesc="The Multiple Git Repository Tool"
arch=('any')
url="https://source.android.com/source/developing.html"
license=('Apache')
-depends=('git' 'python2')
+depends=('git' 'python')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo"
- "python2.patch")
-sha256sums=('SKIP'
- 'bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4')
+source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
cd "$_pkgname"
- patch -Np1 -i "$srcdir"/python2.patch
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {