summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuston Li2015-08-17 17:46:44 -0700
committerJuston Li2015-08-17 17:46:44 -0700
commit7e9c011f0c550bfd326926fb0446de63c352e069 (patch)
treefde0fe2af85bb6c954dcb09a9c29bb4efcdf2db5
parentf39cf11e2a12f949f864e44c0deec4eb24e5bde6 (diff)
downloadaur-7e9c011f0c550bfd326926fb0446de63c352e069.tar.gz
add python2 patch
-rw-r--r--PKGBUILD11
-rw-r--r--python2.patch10
2 files changed, 19 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b9ea7cc2b54..8407378ec98f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,10 @@ license=("APACHE")
depends=("git" "python2")
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo")
-sha256sums=("SKIP")
+source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo"
+ "python2.patch")
+sha256sums=("SKIP"
+ "bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4")
pkgver() {
@@ -21,6 +23,11 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "$srcdir/$_pkgname"
+ patch -p1 < "${srcdir}/python2.patch"
+}
+
package() {
cd "$srcdir/$_pkgname"
install -D -m 755 repo "$pkgdir/usr/bin/repo"
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..ee5335e6f43c
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,10 @@
+diff --git a/repo b/repo2
+index bf8fa3d..24d5554 100755
+--- a/repo
++++ b/repo2
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ ## repo default configuration
+ ##