summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2021-03-20 13:51:36 +0800
committerzhullyb2021-03-20 13:52:07 +0800
commit17be361e2c7cb4684d7dd9cf0f053a391321040d (patch)
treea9fc37a48d146ad0e856826b9ab6d89e775a9eff
downloadaur-17be361e2c7cb4684d7dd9cf0f053a391321040d.tar.gz
Transfer to repo-mokee now
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD26
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eca2cea952f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = repo-mokee
+ pkgdesc = The Multiple Git Repository Tool from the Android Open Source Project
+ pkgver = 2.13.2
+ pkgrel = 1
+ url = https://github.com/mokee/git-repo
+ arch = any
+ license = APACHE
+ depends = git
+ depends = python
+ provides = repo
+ conflicts = repo
+ source = git+https://github.com/MoKee/git-repo.git
+ md5sums = SKIP
+
+pkgname = repo-mokee
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..57d07d47d8be
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+pkg
+src
+git-repo
+*.tar
+*.gz
+*.xz
+*.zst
+*.zip
+*.lz4
+*.lzo
+*.bz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a98ca64b136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: zhullyb <zhullyb@outlook.com>
+
+pkgname=repo-mokee
+pkgver=2.13.2
+pkgrel=1
+pkgdesc="The Multiple Git Repository Tool from the Android Open Source Project"
+url="https://github.com/mokee/git-repo"
+arch=('any')
+license=("APACHE")
+depends=("git" "python")
+provides=('repo')
+conflicts=('repo')
+source=("git+https://github.com/MoKee/git-repo.git")
+
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/git-repo"
+ git describe | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $srcdir/git-repo
+ install -D -m 755 repo "$pkgdir/usr/bin/repo"
+ install -D -m 644 docs/manifest-format.md "$pkgdir/usr/share/doc/$pkgname/manifest-format.md"
+}