summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:45:49 +0200
committerStefan Husmann2015-06-09 00:45:49 +0200
commit8f92b3d9ae1fc1272eed796923611f1c6ba8096a (patch)
treed874acdd133d0dec409fd603135cfc455e2e6a03
downloadaur-8f92b3d9ae1fc1272eed796923611f1c6ba8096a.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23b627c204fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = repoctl-git
+ pkgdesc = A supplement to repo-add and repo-remove which simplifies managing local repositories
+ pkgver = v0.10.5.gabacd3c
+ pkgrel = 1
+ url = https://github.com/cassava/repoctl
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = pacman
+ replaces = repo-keep
+ source = git+https://github.com/cassava/repoctl.git
+ md5sums = SKIP
+
+pkgname = repoctl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a7ba383f92a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Ben Morgan <neembi@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=repoctl-git
+pkgver=v0.10.5.gabacd3c
+pkgrel=1
+pkgdesc="A supplement to repo-add and repo-remove which simplifies managing local repositories"
+arch=('i686' 'x86_64')
+url="https://github.com/cassava/repoctl"
+license=('MIT')
+depends=('pacman')
+makedepends=('go')
+replaces=('repo-keep')
+source=("git+https://github.com/cassava/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags|sed 's/-/./g'
+}
+
+build() {
+ cd ${pkgname%-git}
+ go build
+}
+
+package() {
+ cd ${pkgname%-git}
+ # repo program
+ mkdir -p $pkgdir/usr/bin
+ install -m755 repoctl $pkgdir/usr/bin/
+ # Install other documentation
+ install -m644 TODO README.md NEWS $pkgdir/usr/share/doc/repo-keep/
+ # Install completion files
+ mkdir -p $pkgdir/usr/share/zsh/site-functions/
+ install -m644 contrib/zsh_completion $pkgdir/usr/share/zsh/site-functions/_repoctl
+}