summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2020-03-09 02:02:59 +0800
committerDario Giovannetti2020-03-09 02:03:58 +0800
commit9caf06a46e33b5c637117ee1f12ebedefeb38697 (patch)
tree30393ced9024ee36d5c8ce0e4f82c235a68ebaf0
downloadaur-9caf06a46e33b5c637117ee1f12ebedefeb38697.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41be1a3b3c9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = report-todo
+ pkgdesc = Parse and report TODO, FIXME, BUG etc. comments in source code.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/kynikos/report-todo
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = report-todo-1.0.0.tgz
+ source = https://registry.npmjs.org/report-todo/-/report-todo-1.0.0.tgz
+ sha256sums = b66bc4fda397ebcb694efc8208dfa2f4ad4f2a31869d3a2a560b9251f6610c23
+
+pkgname = report-todo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9648f0f4308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0705f4d0b3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dario Giovannetti <info@dariogiovannetti.net>
+
+pkgname=report-todo
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Parse and report TODO, FIXME, BUG etc. comments in source code."
+arch=('any')
+url="https://github.com/kynikos/report-todo"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz")
+noextract=("${pkgname}-${pkgver}.tgz")
+sha256sums=('b66bc4fda397ebcb694efc8208dfa2f4ad4f2a31869d3a2a560b9251f6610c23')
+
+package() {
+ npm install -g --only=production --user root --prefix "${pkgdir}/usr" \
+ "${srcdir}/${pkgname}-${pkgver}.tgz" --cache "${srcdir}/npm-cache"
+
+ # Non-deterministic race in npm gives 777 permissions to random directories
+ # https://github.com/npm/npm/issues/9359
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+
+ # npm gives ownership of all files to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "../../../lib/node_modules/${pkgname}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}