aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPolarian2023-02-03 12:28:25 +0000
committerPolarian2023-02-03 12:28:25 +0000
commitce5ee92928ff924a864c5f72fe280cb4f06b7017 (patch)
treef897fd4d606651f5dcee294ce4813fdc99599dc6
parent1cb9f39910ad7272b36ce5581c79f3903689c033 (diff)
downloadaur-ce5ee92928ff924a864c5f72fe280cb4f06b7017.tar.gz
Added configuration.cdn to PKGBUILD
-rw-r--r--PKGBUILD9
-rw-r--r--configuration.cdn70
2 files changed, 76 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2831ebae4b3a..fa4c03bc3032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,13 +15,15 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"$pkgname.sysusers"
"$pkgname.tmpfiles"
"$pkgname.env"
- "$pkgname.wrapper")
+ "$pkgname.wrapper"
+ "configuration.cdn")
sha256sums=('79e2cf65a507c33216b11358ec746459331c8157d4089606021f2ed51e66f29c'
'1e543e7ef39d64ae683156aaa6aad8f164f30de999d15717416410e1750b9a8e'
'92ccfeff429aa4757ef353677dd99ad7aebe7483d4824706a27250e81efd6323'
'9587fa49dd66d5f31dee33aa1a9da269a34666b63f62e2550a66c3bc1d397aa7'
'7affcf3ef54c9c05326281c3496a8744221be312675fd7d4ab17fd50eb320521'
- 'f36b16f87dd0cee15d0ec5c11ba28596f4c09df5cf2739f2dce4398737337d3c')
+ 'f36b16f87dd0cee15d0ec5c11ba28596f4c09df5cf2739f2dce4398737337d3c'
+ '4980596324b81b35e76b9bf4841ad82a0780b631a0323b0d8ef1f77fdbc4b76a')
backup=('etc/reposilite/configuration.cdn'
'etc/reposilite/wrapper.env')
@@ -37,6 +39,7 @@ package() {
install -Dm 644 $pkgname.sysusers -t "${pkgdir}/usr/lib/sysusers.d/$pkgname.conf"
install -Dm 644 $pkgname.tmpfiles -t "${pkgdir}/usr/lib/tmpfiles.d/$pkgname.conf"
install -Dm 644 $pkgname-$pkgver/reposilite-backend/build/libs/$pkgname-$pkgver.jar -t "$pkgdir/usr/share/java/$pkgname/$pkgname.jar"
- install -Dm 644 $pkgname.env -t "${pkgdir}/etc/reposilite/wrapper.env"
+ install -Dm 644 configuration.cdn -t "${pkgdir}/etc/reposilite/"
+ install -Dm 644 $pkgname.env -t "${pkgdir}/etc/reposilite/"
install -Dm 755 $pkgname.wrapper -t "${pkgdir}/usr/bin/reposilite"
}
diff --git a/configuration.cdn b/configuration.cdn
new file mode 100644
index 000000000000..a9d78ae34138
--- /dev/null
+++ b/configuration.cdn
@@ -0,0 +1,70 @@
+# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ #
+# Reposilite :: Local #
+# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ #
+
+# Local configuration contains init params for current Reposilite instance.
+# For more options, shared between instances, login to the dashboard with management token and visit 'Configuration' tab.
+
+# Hostname
+# The hostname can be used to limit which connections are accepted.
+# Use 0.0.0.0 to accept connections from anywhere.
+# 127.0.0.1 will only allow connections from localhost.
+hostname: 0.0.0.0
+# Port to bind
+port: 8080
+# Database configuration. Supported storage providers:
+# - mysql localhost:3306 database user password
+# - sqlite reposilite.db
+# - sqlite --temporary
+# Experimental providers (not covered with tests):
+# - postgresql localhost:5432 database user password
+# - h2 reposilite
+database: sqlite reposilite.db
+
+# Support encrypted connections
+sslEnabled: false
+# SSL port to bind
+sslPort: 443
+# Key file to use.
+# You can specify absolute path to the given file or use ${WORKING_DIRECTORY} variable.
+# If you want to use .pem certificate you need to specify its path next to the key path.
+# Example .pem paths setup:
+# keyPath: ${WORKING_DIRECTORY}/cert.pem ${WORKING_DIRECTORY}/key.pem
+# Example .jks path setup:
+# keyPath: ${WORKING_DIRECTORY}/keystore.jks
+keyPath: ${WORKING_DIRECTORY}/cert.pem ${WORKING_DIRECTORY}/key.pem
+# Key password to use
+keyPassword: ""
+# Redirect http traffic to https
+enforceSsl: false
+
+# Max amount of threads used by core thread pool (min: 5)
+# The web thread pool handles first few steps of incoming http connections, as soon as possible all tasks are redirected to IO thread pool.
+webThreadPool: 16
+# IO thread pool handles all tasks that may benefit from non-blocking IO (min: 2)
+# Because most of tasks are redirected to IO thread pool, it might be a good idea to keep it at least equal to web thread pool.
+ioThreadPool: 8
+# Database thread pool manages open connections to database (min: 1)
+# Embedded databases such as SQLite or H2 don't support truly concurrent connections, so the value will be always 1 for them if selected.
+databaseThreadPool: 1
+# Select compression strategy used by this instance.
+# Using 'none' reduces usage of CPU & memory, but ends up with higher transfer usage.
+# GZIP is better option if you're not limiting resources that much to increase overall request times.
+# Available strategies: none, gzip
+compressionStrategy: none
+# Default idle timeout used by Jetty
+idleTimeout: 30000
+
+# Adds cache bypass headers to each request from /api/* scope served by this instance.
+# Helps to avoid various random issues caused by proxy provides (e.g. Cloudflare) and browsers.
+bypassExternalCache: true
+# Amount of messages stored in cached logger.
+cachedLogSize: 32
+# Enable default frontend with dashboard
+defaultFrontend: true
+# Set custom base path for Reposilite instance.
+# It's not recommended to mount Reposilite under custom base path
+# and you should always prioritize subdomain over this option.
+basePath: /
+# Debug mode
+debugEnabled: false