aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Leclerc2023-04-10 14:34:23 +0200
committerGitHub2023-04-10 14:34:23 +0200
commitdfbaa228da2170e1080487340ec88e0dcab91b08 (patch)
tree1009cd593e6529c2363f755f0b90017ab1cfc18e
parentaeae83f7e1485218dd425a83ab72814365e1b92c (diff)
downloadaur-dfbaa228da2170e1080487340ec88e0dcab91b08.tar.gz
Bump version to 3.4.1 (#6)
* Released 3.4.1 * Updated update.sh for github use --------- Co-authored-by: Release bot <hosting@polarian.dev>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xupdate.sh71
3 files changed, 78 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb4a28ad50f5..d635a9a0bb32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = reposilite
pkgdesc = Reposilite (formerly NanoMaven) - lightweight repository manager for Maven artifacts. It is a simple solution to replace managers like Nexus, Archiva or Artifactory.
- pkgver = 3.4.0
- pkgrel = 2
+ pkgver = 3.4.1
+ pkgrel = 1
url = https://reposilite.com
arch = any
license = Apache
@@ -11,13 +11,13 @@ pkgbase = reposilite
depends = java-runtime-headless>=18
backup = etc/reposilite/configuration.cdn
backup = etc/reposilite/default.env
- source = reposilite-3.4.0.tar.gz::https://github.com/dzikoysk/reposilite/archive/3.4.0.tar.gz
+ source = reposilite-3.4.1.tar.gz::https://github.com/dzikoysk/reposilite/archive/3.4.1.tar.gz
source = reposilite.service
source = reposilite.sysusers
source = reposilite.tmpfiles
source = reposilite.env
source = reposilite.wrapper
- sha256sums = bbaa0ff8ec32718433d9ff8906b1dc8bce3a814b8580569e7bcb64aa1fb72c43
+ sha256sums = bc9e801c5b649a6065a32d053afdec774c171508b6edf437651b757752a5156c
sha256sums = 1e543e7ef39d64ae683156aaa6aad8f164f30de999d15717416410e1750b9a8e
sha256sums = 92ccfeff429aa4757ef353677dd99ad7aebe7483d4824706a27250e81efd6323
sha256sums = 9587fa49dd66d5f31dee33aa1a9da269a34666b63f62e2550a66c3bc1d397aa7
diff --git a/PKGBUILD b/PKGBUILD
index afdeb8725514..19a2f4b63b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Co-Maintainer: Polarian <polarian@polarian.dev>
pkgname=reposilite
-pkgver=3.4.0
-pkgrel=2
+pkgver=3.4.1
+pkgrel=1
pkgdesc="Reposilite (formerly NanoMaven) - lightweight repository manager for Maven artifacts. It is a simple solution to replace managers like Nexus, Archiva or Artifactory."
arch=(any)
url="https://reposilite.com"
@@ -16,7 +16,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/dzikoysk/reposilite/archive
"$pkgname.tmpfiles"
"$pkgname.env"
"$pkgname.wrapper")
-sha256sums=('bbaa0ff8ec32718433d9ff8906b1dc8bce3a814b8580569e7bcb64aa1fb72c43'
+sha256sums=('bc9e801c5b649a6065a32d053afdec774c171508b6edf437651b757752a5156c'
'1e543e7ef39d64ae683156aaa6aad8f164f30de999d15717416410e1750b9a8e'
'92ccfeff429aa4757ef353677dd99ad7aebe7483d4824706a27250e81efd6323'
'9587fa49dd66d5f31dee33aa1a9da269a34666b63f62e2550a66c3bc1d397aa7'
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..e845d21fd867
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,71 @@
+#!/bin/bash
+
+set -eo pipefail
+
+usage() { echo -e "Usage: $0 [-f] [-c]\n -i : inital build\n -c : run in cron mode" 1>&2; exit 1; }
+
+cron=
+initial=
+
+while getopts ":ic" o; do
+ case $o in
+ i)
+ initial=y
+ ;;
+ c)
+ cron=y
+ ;;
+ *)
+ usage
+ ;;
+ esac
+done
+
+s_dir="$( cd -- "$( dirname -- "${BASH_SOURCE[0]}" )" &> /dev/null && pwd )"
+cd $s_dir
+
+git checkout master
+git pull -p --ff-only
+
+if git branch -r | grep release/ &>/dev/null; then
+ echo "Remote release branch detected ; will not create another, exiting"
+ exit
+fi
+
+build_ver=`grep ^pkgver= PKGBUILD | cut -d= -f2`
+release_ver=`curl --silent "https://api.github.com/repos/dzikoysk/reposilite/releases/latest" | jq -r .tag_name`
+new_ver=`echo -e "$release_ver\n$build_ver" | sort -rV | head -n 1`
+
+if [ $new_ver = $build_ver -a "${initial}x" = "x" ] ; then
+ exit
+fi
+
+if [ "${initial}x" = "x" ] ; then
+ echo "New version available: $new_ver (last build is $build_ver)"
+ sed -i -e "s/^pkgver=.*/pkgver=$new_ver/" PKGBUILD
+ sed -i -e "s/^pkgrel=.*/pkgrel=1/" PKGBUILD
+ updpkgsums -m
+else
+ cd ..
+ echo "Building version $build_ver (initial)"
+fi
+
+echo "Building package"
+if [ "${cron}x" = "yx" ] ; then
+ time (makepkg --skippgpcheck -CcLm > $s_dir/build.log)
+else
+ time (makepkg --skippgpcheck -CcLm | tee $s_dir/build.log)
+fi
+
+if [ "${initial}x" = "x" ] ; then
+ makepkg --printsrcinfo > .SRCINFO
+ git checkout -b release/$new_ver
+ git add PKGBUILD .SRCINFO
+ git commit -m "Released $new_ver"
+ git push -u origin release/$new_ver
+ gh pr create --title "Bump version to $new_ver" --body "Bump version to $new_ver" --assignee PolarianDev
+ git checkout master
+ git branch -D release/$new_ver
+ rm reposilite-$new_ver.tar.*
+ rm reposilite-$new_ver-1-any.pkg.tar.*
+fi