summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpaulbdavis2018-02-25 14:01:21 -0700
committerpaulbdavis2018-02-25 14:01:21 -0700
commit158d7c89a7594d4c34af6247eb3ca1d4b84d7e4d (patch)
tree1414285b834f3b5d4861211557305157a5c6d62e
parentd81e50290573f9108cc83ce7e00976022d45ae00 (diff)
downloadaur-158d7c89a7594d4c34af6247eb3ca1d4b84d7e4d.tar.gz
another cp fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--reposync.sh5
3 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e425ce789859..7be799619881 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = reposync
pkgdesc = Wrapper for aursync
- pkgver = 0.0.11
+ pkgver = 0.0.12
pkgrel = 1
arch = any
license = MIT
@@ -9,7 +9,7 @@ pkgbase = reposync
depends = bash
depends = s3fs-fuse
source = reposync.sh
- sha256sums = 1b1149663c14f1d7bfa39556866f07960e4f922a68eb603e11d0783cddd4ae0c
+ sha256sums = bceac8b4ae65789f18549aa46b9b651951298348196d2102920382a66c473327
pkgname = reposync
diff --git a/PKGBUILD b/PKGBUILD
index b59ea7ca455c..bb362a61cddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Paul Davis <paul@dangersalad.com>
pkgname=reposync
-pkgver=0.0.11
+pkgver=0.0.12
pkgrel=1
arch=('any')
license=('MIT')
source=(reposync.sh)
pkgdesc="Wrapper for aursync"
-sha256sums=('1b1149663c14f1d7bfa39556866f07960e4f922a68eb603e11d0783cddd4ae0c')
+sha256sums=('bceac8b4ae65789f18549aa46b9b651951298348196d2102920382a66c473327')
depends=('aurutils' 'sudo' 'bash' 's3fs-fuse')
package () {
diff --git a/reposync.sh b/reposync.sh
index 07b55e3d0c2c..1aa50191a7cc 100644
--- a/reposync.sh
+++ b/reposync.sh
@@ -72,9 +72,14 @@ echo "Performing repository sync"
aursync --sign --repo "$repo_name" --root "$local_repo" -u $@
(
+
cd "$local_repo"
+ rm -f "$db_remote_name" "${db_remote_name}.sig"
+ rm -f "$files_remote_name" "${files_remote_name}.sig"
cp -af "$db_local_name" "$db_remote_name"
+ cp -af "${db_local_name}.sig" "${db_remote_name}.sig"
cp -af "$files_local_name" "$files_remote_name"
+ cp -af "${files_local_name}.sig" "${files_remote_name}.sig"
)
echo "Syncing local repo to remote"