summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpaulbdavis2018-02-25 14:27:42 -0700
committerpaulbdavis2018-02-25 14:27:42 -0700
commit970e03649bab1d2442edeb95d9b80b8df89c2bfb (patch)
tree23f18e1a7986bb19937500036b71fe481fbbf5d5
parent651e67f1b4fbcfddf200e2bad50535ba8d040c15 (diff)
downloadaur-970e03649bab1d2442edeb95d9b80b8df89c2bfb.tar.gz
fix that, also remove old sigs so there is no prompt
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--reposync.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18d8252a72fb..ec89b17018ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = reposync
pkgdesc = Wrapper for aursync
- pkgver = 0.0.13
+ pkgver = 0.0.14
pkgrel = 1
arch = any
license = MIT
@@ -9,7 +9,7 @@ pkgbase = reposync
depends = bash
depends = s3fs-fuse
source = reposync.sh
- sha256sums = 7fff2cd8588663a26394fa64f77c2703720550744b0dc259da0dad54bbe70cdb
+ sha256sums = e0384d1fd771812c245355d974a9f4906fa0874caf8433f8283d23f8102366d3
pkgname = reposync
diff --git a/PKGBUILD b/PKGBUILD
index 9ddb5ec68fcf..d48fee755011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Paul Davis <paul@dangersalad.com>
pkgname=reposync
-pkgver=0.0.13
+pkgver=0.0.14
pkgrel=1
arch=('any')
license=('MIT')
source=(reposync.sh)
pkgdesc="Wrapper for aursync"
-sha256sums=('7fff2cd8588663a26394fa64f77c2703720550744b0dc259da0dad54bbe70cdb')
+sha256sums=('e0384d1fd771812c245355d974a9f4906fa0874caf8433f8283d23f8102366d3')
depends=('aurutils' 'sudo' 'bash' 's3fs-fuse')
package () {
diff --git a/reposync.sh b/reposync.sh
index f11c838482bd..63457b8149cc 100644
--- a/reposync.sh
+++ b/reposync.sh
@@ -61,7 +61,9 @@ files_remote_name="${repo_name}.files"
echo "Adding $pkg"
repo-add "$db_local_name" "$pkg"
done
+ rm -f "${db_remote_name}.sig"
gpg --output "${db_remote_name}.sig" --detach-sign "$db_local_name"
+ rm -f "${files_remote_name}.sig"
gpg --output "${files_remote_name}.sig" --detach-sign "$files_local_name"
)
@@ -85,5 +87,5 @@ aursync --sign --repo "$repo_name" --root "$local_repo" -u $@
echo "Syncing local repo to remote"
echo "$local_repo/ -> $remote_repo/"
$do_rsync "$local_repo/" "$remote_repo/"
-$do_rsync -c "$local_repo/dangersalad.db.*" "$remote_repo/"
-$do_rsync -c "$local_repo/dangersalad.files.*" "$remote_repo/"
+$do_rsync -c "$local_repo"/dangersalad.db.* "$remote_repo/"
+$do_rsync -c "$local_repo"/dangersalad.files.* "$remote_repo/"