summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpaulbdavis2018-02-25 14:58:50 -0700
committerpaulbdavis2018-02-25 14:58:50 -0700
commitffac629fdcd51c61bc35e4c6fad0567e273467db (patch)
tree83f655dcc11365185ec4831eddcd248cb74603e4
parent6866fa52c506675c108e5269572bd33be59c9420 (diff)
downloadaur-ffac629fdcd51c61bc35e4c6fad0567e273467db.tar.gz
fix signature signing
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--reposync.sh5
3 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac27d434c243..05794984ef5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = reposync
pkgdesc = Wrapper for aursync
- pkgver = 0.0.17
+ pkgver = 0.0.18
pkgrel = 1
arch = any
license = MIT
@@ -9,7 +9,7 @@ pkgbase = reposync
depends = bash
depends = s3fs-fuse
source = reposync.sh
- sha256sums = eb0b603f1cb59623d546575257a1a05293ebda44352119b5378153c997d7af33
+ sha256sums = c512a1ee7408fa9776d96fdff49f396cd83733be96486f752be9d45e8b8790b2
pkgname = reposync
diff --git a/PKGBUILD b/PKGBUILD
index 683fb154eace..7147c317ca77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Paul Davis <paul@dangersalad.com>
pkgname=reposync
-pkgver=0.0.17
+pkgver=0.0.18
pkgrel=1
arch=('any')
license=('MIT')
source=(reposync.sh)
pkgdesc="Wrapper for aursync"
-sha256sums=('eb0b603f1cb59623d546575257a1a05293ebda44352119b5378153c997d7af33')
+sha256sums=('c512a1ee7408fa9776d96fdff49f396cd83733be96486f752be9d45e8b8790b2')
depends=('aurutils' 'sudo' 'bash' 's3fs-fuse')
package () {
diff --git a/reposync.sh b/reposync.sh
index ee419115a81e..930e16e48550 100644
--- a/reposync.sh
+++ b/reposync.sh
@@ -76,13 +76,12 @@ echo "Performing repository sync"
aursync --sign --repo "$repo_name" --root "$local_repo" -u $@
(
-
cd "$local_repo"
# copy newly generated database files to their remote location
mv "$db_local_name" "$db_remote_name"
mv "$files_local_name" "$files_remote_name"
- mv "${db_local_name}.sig" "$db_remote_name"
- mv "${files_local_name}.sig" "$files_remote_name"
+ mv "${db_local_name}.sig" "${db_remote_name}.sig"
+ mv "${files_local_name}.sig" "${files_remote_name}.sig"
# remove all the extras
rm -f "${db_local_name}"*
rm -f "${files_local_name}"*