summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2019-05-23 16:02:31 +0200
committerRichard Neumann2019-05-23 16:02:31 +0200
commit3c549440e1ca9028f3f72970991228f8209e6e34 (patch)
tree9a60c6dc268b69ef8007cebc71bc945738042771
downloadaur-3c549440e1ca9028f3f72970991228f8209e6e34.tar.gz
Init.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..262eb8cf6086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = repotool
+ pkgdesc = An arch linux repository management tool
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/coNQP/repotool
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = python
+ source = git+https://github.com/coNQP/repotool.git#tag=1.0.0
+ md5sums = SKIP
+
+pkgname = repotool
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b57ffe875df
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+repotool*
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4deabb9253b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+pkgname='repotool'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='An arch linux repository management tool'
+arch=('any')
+url="https://github.com/coNQP/${pkgname}"
+license=('GPLv3')
+depends=('python')
+makedepends=('git')
+source=("git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}