summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Sarboni2015-06-18 16:26:52 +0200
committerThomas Sarboni2015-06-18 16:26:52 +0200
commitf9a66166f12b3aecfc8b3c07c3ce857bf39345a0 (patch)
tree37bcf695d1c14ed496269e5041028bbed966d872
downloadaur-f9a66166f12b3aecfc8b3c07c3ce857bf39345a0.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0707f88718f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = reprepro
+ pkgdesc = A tool to handle local repositories of Debian packages
+ pkgver = 4.16.0
+ pkgrel = 1
+ url = http://mirrorer.alioth.debian.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = db
+ depends = gpgme
+ depends = zlib
+ depends = bzip2
+ depends = libarchive
+ optdepends = apt: Importing from other sources
+ source = http://ftp.debian.org/debian/pool/main/r/reprepro/reprepro_4.16.0.orig.tar.gz
+ sha256sums = fdd2cae3f23b26e3b44734925af5afb76486a46bde104254eb04d8344d98f591
+
+pkgname = reprepro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c085950f21fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Andre Klitzing <andre AT incubo DOT de>
+# Maintainer: max-k <max-k AT post DOT com>
+
+pkgname=reprepro
+pkgver=4.16.0
+pkgrel=1
+pkgdesc="A tool to handle local repositories of Debian packages"
+arch=('i686' 'x86_64')
+url="http://mirrorer.alioth.debian.org"
+license=('GPL')
+depends=('db' 'gpgme' 'zlib' 'bzip2' 'libarchive')
+optdepends=('apt: Importing from other sources')
+source=("http://ftp.debian.org/debian/pool/main/r/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz")
+sha256sums=('fdd2cae3f23b26e3b44734925af5afb76486a46bde104254eb04d8344d98f591')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}