summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tia2023-08-28 20:52:25 -0600
committerJavier Tia2023-08-28 20:52:25 -0600
commit30f517771c552b1fbd873895f0a493091a9de471 (patch)
treee0a655deb78e24e448d5647eab9f414885b71388
parentbb6dcceedb9065bd8918b9274b507ed09d641ab2 (diff)
downloadaur-30f517771c552b1fbd873895f0a493091a9de471.tar.gz
Bump up reproc v14.2.4-2
Signed-off-by: Javier Tia <javier.tia@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--fix-gcc13-build.patch26
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7326fdd62f18..3cdf86190675 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = reproc
pkgdesc = Cross-platform library that simplifies working with external CLI applications from C and C++
pkgver = 14.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/DaanDeMeyer/reproc
arch = x86_64
license = MIT
makedepends = cmake
makedepends = gcc
source = https://github.com/DaanDeMeyer/reproc/archive/v14.2.4.tar.gz
+ source = fix-gcc13-build.patch
sha256sums = 55c780f7faa5c8cabd83ebbb84b68e5e0e09732de70a129f6b3c801e905415dd
+ sha256sums = b6b06e3726de562cd108ee0db665b09befe55de719dea84fc8606be895c30ba0
pkgname = reproc
diff --git a/PKGBUILD b/PKGBUILD
index be65c5089cd0..49554b6b3af7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,21 @@
pkgname=reproc
pkgver=14.2.4
-pkgrel=1
+pkgrel=2
pkgdesc='Cross-platform library that simplifies working with external CLI applications from C and C++'
arch=('x86_64')
url='https://github.com/DaanDeMeyer/reproc'
license=('MIT')
makedepends=('cmake' 'gcc')
-source=("${url}/archive/v${pkgver}".tar.gz)
-sha256sums=('55c780f7faa5c8cabd83ebbb84b68e5e0e09732de70a129f6b3c801e905415dd')
+source=("${url}/archive/v${pkgver}.tar.gz"
+ "fix-gcc13-build.patch")
+sha256sums=('55c780f7faa5c8cabd83ebbb84b68e5e0e09732de70a129f6b3c801e905415dd'
+ 'b6b06e3726de562cd108ee0db665b09befe55de719dea84fc8606be895c30ba0')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}"/fix-gcc13-build.patch
+}
build() {
cmake \
diff --git a/fix-gcc13-build.patch b/fix-gcc13-build.patch
new file mode 100644
index 000000000000..dca643af5c82
--- /dev/null
+++ b/fix-gcc13-build.patch
@@ -0,0 +1,26 @@
+--- a/reproc++/include/reproc++/reproc.hpp 2023-08-28 20:48:34.592494191 -0600
++++ b/reproc++/include/reproc++/reproc.hpp 2023-08-28 20:49:05.695674776 -0600
+@@ -88,18 +88,18 @@
+
+ struct options {
+ struct {
+- env::type behavior;
++ reproc::env::type behavior;
+ /*! Implicitly converts from any STL container of string pairs to the
+ environment format expected by `reproc_start`. */
+- class env extra;
++ reproc::env extra;
+ } env = {};
+
+ const char *working_directory = nullptr;
+
+ struct {
+- redirect in;
+- redirect out;
+- redirect err;
++ reproc::redirect in;
++ reproc::redirect out;
++ reproc::redirect err;
+ bool parent;
+ bool discard;
+ FILE *file;