summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Milam2017-07-13 21:35:24 -0400
committerJustin Milam2017-07-13 21:35:24 -0400
commit8cba3bbda5ac04c5325f738745b069848144e4cc (patch)
tree2ae262af27f585065becd2372b1b51dd10aec8f3
downloadaur-8cba3bbda5ac04c5325f738745b069848144e4cc.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19cf5aaa0744
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = republicanywhere-bin
+ pkgdesc = Republic Anywhere desktop client.
+ pkgver = 1.1.8
+ pkgrel = 1
+ url = republicwireless.com
+ arch = x86_64
+ license = EULA
+ depends = libappindicator-gtk2
+ noextract = republicanywhere_1.1.8_amd64.deb
+ source = http://files.republicwireless.com/public/apps/anywhere/debian/pool/main/r/republicanywhere/republicanywhere_1.1.8_amd64.deb
+ sha256sums = d57474f318521a174cc8236e4361de0fa4564ea29b167f37ec3d1ce219b1d481
+
+pkgname = republicanywhere-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b04367675ef1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.deb
+*.log.*
+*.tar.gz
+*.xz
+*.log
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8501c1198b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=republicanywhere-bin
+pkgver=1.1.8
+pkgrel=1
+pkgdesc="Republic Anywhere desktop client."
+arch=('x86_64')
+url="republicwireless.com"
+license=('EULA')
+depends=(libappindicator-gtk2)
+source=("http://files.republicwireless.com/public/apps/anywhere/debian/pool/main/r/republicanywhere/republicanywhere_${pkgver}_amd64.deb")
+deb="${source[@]##*/}"
+noextract=($deb)
+sha256sums=('d57474f318521a174cc8236e4361de0fa4564ea29b167f37ec3d1ce219b1d481')
+
+prepare() {
+ ar p $deb data.tar.xz | tar xJ
+}
+
+package() {
+ mv usr $pkgdir/. || return 1
+}