summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 11:56:46 +1000
committerJonathan Liu2015-06-19 11:56:46 +1000
commitaac3103662fb648d5ebe8d62b1cc92b0a8138105 (patch)
tree609841cb10e1a18e6eeeca49ac99fb13db1d58c4
downloadaur-aac3103662fb648d5ebe8d62b1cc92b0a8138105.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4e0df727b73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = resample
+ pkgdesc = Sampling-rate conversion and filter design utilities
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = http://ccrma.stanford.edu/~jos/resample/Free_Resampling_Software.html
+ arch = i686
+ arch = x86_64
+ license = LGPL2
+ depends = glibc
+ source = http://ccrma.stanford.edu/~jos/gz/resample-1.8.1.tar.gz
+ md5sums = c3c1c64e4bb9b0bdc6062b8ad619aef1
+
+pkgname = resample
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6243ce95027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Jonathan Liu <net147@gmail.com>
+pkgname=resample
+pkgver=1.8.1
+pkgrel=1
+pkgdesc="Sampling-rate conversion and filter design utilities"
+arch=('i686' 'x86_64')
+url="http://ccrma.stanford.edu/~jos/resample/Free_Resampling_Software.html"
+license=('LGPL2')
+depends=('glibc')
+source=("http://ccrma.stanford.edu/~jos/gz/$pkgname-$pkgver.tar.gz")
+md5sums=('c3c1c64e4bb9b0bdc6062b8ad619aef1')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: