summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsyrique Thevendran2016-07-10 19:09:55 +0700
committerAsyrique Thevendran2016-07-10 19:09:55 +0700
commit198af64e97ea447f1ed8ffdfe1c9dad51d5f2065 (patch)
tree65dba31fd9d5dc0410be949a6f81961b78de982b
parent79ef76cd69fb348a8f2394e4ff6d4ff0a658a5b2 (diff)
downloadaur-198af64e97ea447f1ed8ffdfe1c9dad51d5f2065.tar.gz
Update changelog and .SRCINFO
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
-rw-r--r--rescuetime.changelog111
3 files changed, 131 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 621b290a3219..cd101cffd1d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rescuetime
pkgdesc = Application time-tracking for Linux. Stable version
- pkgver = 2.8.9.1185
- pkgrel = 1
+ pkgver = 2.9.10.1255
+ pkgrel = 3
url = https://www.rescuetime.com
install = rescuetime.install
changelog = rescuetime.changelog
@@ -12,8 +12,10 @@ pkgbase = rescuetime
depends = xorg-xprop
depends = xprintidle
conflicts = rescuetime-beta
- source = https://www.rescuetime.com/installers/rescuetime_current_amd64.deb
- md5sums = 905cf3b44940ce83031d40c96694f680
+ source_i686 = https://www.rescuetime.com/installers/rescuetime_current_i386.deb
+ md5sums_i686 = 79ef7170b5e047712751fa769fd21465
+ source_x86_64 = https://www.rescuetime.com/installers/rescuetime_current_amd64.deb
+ md5sums_x86_64 = bd81f31fbb13a5b73ac5bf41bbf243f6
pkgname = rescuetime
diff --git a/PKGBUILD b/PKGBUILD
index 19a89a842e7c..3ba0167b66b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Maintainer: Limao Luo <luolimao+AUR@gmail.com>
+# Maintainer: Asyrique Thevendran <asyrique+AUR@gmail.com>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
# Contributor: kaptoxic dragos240
pkgname=rescuetime
pkgver=2.9.10.1255
-pkgrel=1
+pkgrel=3
pkgdesc="Application time-tracking for Linux. Stable version"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url=https://www.rescuetime.com
-license=(GPL2)
-depends=(qt4 xorg-xprop xprintidle)
+license=('GPL2')
+depends=('qt4' 'xorg-xprop' 'xprintidle')
conflicts=($pkgname-beta)
install=$pkgname.install
changelog=$pkgname.changelog
+source_i686=("$url/installers/${pkgname}_current_i386.deb")
+source_x86_64=("$url/installers/${pkgname}_current_amd64.deb")
+md5sums_i686=('79ef7170b5e047712751fa769fd21465')
+md5sums_x86_64=('bd81f31fbb13a5b73ac5bf41bbf243f6')
-if [[ $CARCH == "x86_64" ]]
-then
- _suffix=amd64
-md5sums=('bd81f31fbb13a5b73ac5bf41bbf243f6')
-else
- _suffix=i386
-md5sums=('79ef7170b5e047712751fa769fd21465')
-fi
+pkgver() {
+ grep Version control | cut --fields=2 -d' '
+}
-source=($url/installers/rescuetime_current_$_suffix.deb)
+prepare() {
+ bsdtar -xf control.tar.gz control
+ bsdtar -xf data.tar.gz
+}
package() {
- bsdtar -xf data.tar.gz
- install -Dm755 usr/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm755 usr/share/$pkgname/curl-ca-bundle.crt "$pkgdir"/usr/share/$pkgname/curl-ca-bundle.crt
+ install -Dm644 {,"$pkgdir"/}usr/share/$pkgname/curl-ca-bundle.crt
+ install -Dm755 {,"$pkgdir"/}usr/bin/$pkgname
}
diff --git a/rescuetime.changelog b/rescuetime.changelog
index 60a138e35ab7..2344eabdc9ff 100644
--- a/rescuetime.changelog
+++ b/rescuetime.changelog
@@ -1,13 +1,114 @@
RescueTime for Linux Release Notes
-2.8.5.890 - 2013/11/19 (Beta)
+2.9.10.1255 - 2016/04/21 (Release)
+
+Changes
+
+ Fixed issue where Chrome was not collecting website information.
+ Removed a major memory leak while collecting website information in Chrome/Firefox.
+ Optimized Chrome website collection.
+
+2.9.10.1250 - 2016/04/15
+
+Changes
+
+ Updated a software dependency to fix an issue on Windows with RescueTime keeping the computer awake.
+
+2.9.10.1230 - 2015/12/17
+
+Changes
+
+ Forcing SSL usage and verifying peer for more secure communications.
+
+2.8.9.1185 - 2015/8/31
+
+Changes
+
+ Fix for opening more than just http:// links from RescueTime alerts.
+
+2.8.9.1170 - 2015/7/9
+
+Changes
+
+ FocusTime end notifying server for other IFTTT / Zapier services.
+
+2.8.9.1165 - 2015/6/10
+
+Changes
+
+ FocusTime duration sent to server when starting session.
+ Removed information from debug log, unless higher logging level is used.
+
+2.8.9.1160 - 2015/6/4
+
+Changes
+
+ Fixed the secondary window title collector, removed extra string and quotes.
+ Now encoding the FocusTime redirect URL.
+
+2.8.9.1155 - 2015/5/28
+
+Changes
+
+ Fix for configuration loading issue with OfflineTime labels containing - or ,
+ Added more debug prints to track down crashing issues.
+
+2.8.9.1150 - 2015/5/7
+
+Changes
+
+ Release of Menu changes and fixed ui threading crashes.
+ Fixed pause for 60 minutes displaying until midnight.
+
+2.8.9.1145 - 2015/5/4
+
+Changes
+
+ Modified Menu to show Pause and Focus time remaining, change to Unpause button.
+ Testing a FocusTime shutoff command from server.
+ Fix for google-chrome-unstable location.
+ Fix for google-chrome location changes for communicating with extension.
+ Several fixed regardning the new menu system.
+ Fix for two possible ui thread crashes.
+
+2.8.8.1040 - 2015/2/3
+
+ Idle Activity feature to not go idle for some period of time with specific activities (for movies).
+ Support for firefox-dev to collect website information.
+
+2.8.7.1025 - 2014/12/29
+
+ Idle Activity feature to not go idle for some period of time with specific activities.
+ Support information shows premium/lite status for diagnostic purposes.
+ Support for chrome-stable to collect website information.
+
+2.8.6.1015 - 2014/07/11
+
+Changes
+
+ Update data version of activity reporting to distinguish between offline and other activities.
+ Removed a misleading cause for unknown default error, should have more information.
+ Fixed user:taken issue when signing in with new user.
+
+2.8.6.988 - 2014/03/31
+
+Bugs Fixed
+
+ Fixed issue with FocusTime not turning off.
+ Updated activation process.
+ Removed the excessive "unknown default error" status report.
+
+2.8.5.964 - 2013/11/21
Bugs Fixed
- Reduced server load for activation.
- Disabled text entry and button on FocusTime window for lite users.
- Fixed possible but unlikely crash when loading configuration at startup.
+ Reduced server load for activation.
+ Disabled text entry and button on FocusTime window for lite users.
+ Fixed possible but unlikely crash when loading configuration at startup.
+ Fixed crash with alert messages.
+ Fixed issue with seconds vs milliseconds with delay before reading url.
+ Other minor bug fixes and maintenance.
-2.8.5.870 - 2013/11/14 (Release)
+2.8.5.870 - 2013/11/14
Bugs Fixed