summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVoxelCubes2021-07-11 05:36:41 +0200
committerVoxelCubes2021-07-11 05:36:41 +0200
commiteb3baffe15067bc7d7d9fd0ced39bde66bf43235 (patch)
treea1cc82461f527f49f28d5a50e1c41e42fc8908b5
downloadaur-eb3baffe15067bc7d7d9fd0ced39bde66bf43235.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..866d4ed5f8e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = resistor-decoder
+ pkgdesc = Qt GUI tool for through-hole resistors and SMD parts.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/VoxelCubes/ResistorDecoder
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = pyside6
+ depends = python>=3.6.0
+ depends = qt6-svg
+ source = ResistorDecoder-1.0.tar.gz::https://github.com/VoxelCubes/ResistorDecoder/releases/download/1.0/ResistorDecoder-1.0.tar.gz
+ sha256sums = e884c6f63aef7fe8bd062e439b687d725f87c48d137c0a2837cf2ac5065a8e16
+
+pkgname = resistor-decoder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55313e9514da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Voxel <voxel.aur@gmail.com>
+pkgname=resistor-decoder
+pkgver=1.0
+pkgrel=1
+pkgdesc="Qt GUI tool for through-hole resistors and SMD parts."
+arch=("any")
+url="https://github.com/VoxelCubes/ResistorDecoder"
+license=('GPL')
+depends=("pyside6" "python>=3.6.0" "qt6-svg")
+makedepends=("python-setuptools")
+realpkgname=ResistorDecoder
+source=("${realpkgname}-$pkgver.tar.gz::${url}/releases/download/${pkgver}/${realpkgname}-$pkgver.tar.gz")
+sha256sums=("e884c6f63aef7fe8bd062e439b687d725f87c48d137c0a2837cf2ac5065a8e16")
+
+
+package() {
+ cd "${srcdir}/${realpkgname}/"
+
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ install --mode=644 --owner=root --group=root "ResistorDecoder.desktop" "$pkgdir/usr/share/applications/"
+
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ install --mode=644 --owner=root --group=root "resistor_decoder.png" "$pkgdir/usr/share/pixmaps/resistor_decoder.png"
+}