summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2020-09-29 18:22:54 -0400
committerKevin MacMartin2020-09-29 18:22:54 -0400
commit27791c3a3970ac9547e4a474e1e9a2c82efd889b (patch)
tree1ecc615228c5e195ecd6820be6bf9ac4fc7ef804
parentd00d14f1ef867f84faa888f217c603fa500739b7 (diff)
downloadaur-27791c3a3970ac9547e4a474e1e9a2c82efd889b.tar.gz
Patch out the impossible-to-close donation notification
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--remove-buggy-notification.patch20
3 files changed, 27 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa2a1d183833..746f09dbbb2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = responsively
pkgdesc = A modified browser built using Electron that helps in responsive web development
pkgver = 0.13.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/responsively-org/responsively-app
arch = i686
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = responsively
source = https://github.com/responsively-org/responsively-app/archive/v0.13.2.tar.gz
source = responsively.desktop
source = fix-build.patch
+ source = remove-buggy-notification.patch
sha512sums = 72ea2d83e11ee56e2c14883a31e9eefee439e54bd65ab186948b658d3a84d5e93d8620db0eeb9db79761816b7c92190833c4e41885d129d57ac4110f606ac10c
sha512sums = eebe6acbb675d8804d87e34f6a005f55268ef8927e7bb1c7199791dfdbd4c3839ffe61ba2e59c23359dc9cbbfd74bed9d9610d0cd71e9961666b8167b3a04c33
sha512sums = 80ac98d5ff17c5b1685164921c3e5ab04f365df7e24741a722afd1603b3a7bcf20f2d41f05ed1e37c630c07276a93a4424a2b8fa27fc98fafa8dfc393c7e7fd4
+ sha512sums = b3f20bab0962e96eef55479327c4e695480b08318e8cb508393702adf465f3fa372fc44859b299f6706c879ba62fc5e5bfc56b25b477ca33fa38c343dfbaf85e
pkgname = responsively
diff --git a/PKGBUILD b/PKGBUILD
index 558647f8d1dc..8b82664454fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=responsively
pkgver=0.13.2
-pkgrel=1
+pkgrel=2
pkgdesc='A modified browser built using Electron that helps in responsive web development'
url='https://github.com/responsively-org/responsively-app'
license=('AGPL3')
@@ -15,17 +15,20 @@ source=(
"https://github.com/responsively-org/responsively-app/archive/v$pkgver.tar.gz"
"$pkgname.desktop"
'fix-build.patch'
+ 'remove-buggy-notification.patch'
)
sha512sums=(
'72ea2d83e11ee56e2c14883a31e9eefee439e54bd65ab186948b658d3a84d5e93d8620db0eeb9db79761816b7c92190833c4e41885d129d57ac4110f606ac10c'
'eebe6acbb675d8804d87e34f6a005f55268ef8927e7bb1c7199791dfdbd4c3839ffe61ba2e59c23359dc9cbbfd74bed9d9610d0cd71e9961666b8167b3a04c33'
'80ac98d5ff17c5b1685164921c3e5ab04f365df7e24741a722afd1603b3a7bcf20f2d41f05ed1e37c630c07276a93a4424a2b8fa27fc98fafa8dfc393c7e7fd4'
+ 'b3f20bab0962e96eef55479327c4e695480b08318e8cb508393702adf465f3fa372fc44859b299f6706c879ba62fc5e5bfc56b25b477ca33fa38c343dfbaf85e'
)
prepare() {
cd $pkgname-app-$pkgver
patch -p1 < ../fix-build.patch
+ patch -p1 < ../remove-buggy-notification.patch
}
build() {
diff --git a/remove-buggy-notification.patch b/remove-buggy-notification.patch
new file mode 100644
index 000000000000..b56c1457e727
--- /dev/null
+++ b/remove-buggy-notification.patch
@@ -0,0 +1,20 @@
+diff --git a/desktop-app/app/components/Header/index.js b/desktop-app/app/components/Header/index.js
+index 1cc5f88..58f3e29 100644
+--- a/desktop-app/app/components/Header/index.js
++++ b/desktop-app/app/components/Header/index.js
+@@ -10,7 +10,6 @@ import PermissionPopup from '../PermissionPopup';
+
+ import NavigationControlsContainer from '../../containers/NavigationControlsContainer';
+ import BookmarksBar from '../../containers/BookmarksBarContainer';
+-import AppNotification from '../AppNotification/AppNotification';
+ import Logo from '../icons/Logo';
+
+ const Header = () => {
+@@ -52,7 +51,6 @@ const Header = () => {
+ pauseOnHover
+ toastClassName={classes.darkToast}
+ />
+- <AppNotification />
+ </div>
+ );
+ };