summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Westrup2021-12-03 19:49:00 +0100
committerErik Westrup2021-12-03 19:49:00 +0100
commit0aedc8ef9851cf578fe377f6a2140a66a9622d43 (patch)
tree0e9e5221533ab12039a1e9d24d4fc716c889c36a
parent88e7a87f89ca64636bf4583924067ba86eebfd36 (diff)
downloadaur-0aedc8ef9851cf578fe377f6a2140a66a9622d43.tar.gz
Update to v1.0.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c9dfbc3ee9c..56bb9a504410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = restic-systemd-automatic-backup
- pkgdesc = Backup solution using restic/Backblaze B2 storage.
- pkgver = 1.0.0
+ pkgdesc = Backup solution using restic with Backblaze B2 storage backend.
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/erikw/restic-systemd-automatic-backup
arch = any
license = BSD
license = custom
- makedepends = git
depends = systemd
depends = restic
backup = etc/restic/b2_env.sh
backup = etc/restic/b2_pw.txt
backup = etc/restic/backup_exclude
- source = https://github.com/erikw/restic-systemd-automatic-backup/archive/v1.0.0.tar.gz
- sha256sums = 3efc6793954b232e497fb05db48aec0c174d64ccddda89432f253e6e74b66476
+ source = https://github.com/erikw/restic-systemd-automatic-backup/archive/v1.0.1.tar.gz
+ sha256sums = 10f8b99c70e7ae8abdb2670edd323f11d7fe8f1b5ecafaa7e0d3c01b1658e290
pkgname = restic-systemd-automatic-backup
diff --git a/PKGBUILD b/PKGBUILD
index 3825ba777262..16276a3abca3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Todd E Johnson <todd@toddejohnson.net>
+# Maintainer: Erik Westrup <erik.westrup@gmail.com>
pkgname=restic-systemd-automatic-backup
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
-pkgdesc="Backup solution using restic/Backblaze B2 storage."
-arch=('any')
+pkgdesc="Backup solution using restic with Backblaze B2 storage backend."
+arch=('any')
url="https://github.com/erikw/restic-systemd-automatic-backup"
license=('BSD' 'custom')
depends=('systemd' 'restic')
-makedepends=('git')
source=("https://github.com/erikw/restic-systemd-automatic-backup/archive/v$pkgver.tar.gz")
-sha256sums=('3efc6793954b232e497fb05db48aec0c174d64ccddda89432f253e6e74b66476')
+sha256sums=('10f8b99c70e7ae8abdb2670edd323f11d7fe8f1b5ecafaa7e0d3c01b1658e290')
backup=('etc/restic/b2_env.sh' 'etc/restic/b2_pw.txt' 'etc/restic/backup_exclude')
package() {
cd "$pkgname-$pkgver"
- mv etc/restic/b2_env.sh.template etc/restic/b2_env.sh
- mv etc/restic/b2_pw.txt.template etc/restic/b2_pw.txt
- make PREFIX="$pkgdir" DEST_SCRIPTS="$pkgdir/usr/bin" DEST_SYSTEMD="$pkgdir/usr/lib/systemd/system" install
+ make PREFIX="$pkgdir" DEST_SCRIPTS="$pkgdir/usr/bin" DEST_SYSTEMD="$pkgdir/usr/lib/systemd/system" install
sed -e 's|/usr/local/sbin|/usr/bin|g' -i $pkgdir/usr/lib/systemd/system/*
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}