summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Daniel2015-08-17 20:01:42 +0200
committerFlorian Daniel2015-08-17 20:01:42 +0200
commit02fad4b6b2e47ae4cd69acd66816e3301016df9f (patch)
tree06b2d9712ecd35c3497676500e1c7cc1ba121058
downloadaur-02fad4b6b2e47ae4cd69acd66816e3301016df9f.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f80abb18644
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = restic-git
+ pkgdesc = restic is a program that does backups right.
+ pkgver = r702.c143f8c
+ pkgrel = 1
+ url = https://github.com/restic/restic
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = go>=1.3
+ depends = glibc
+ provides = restic
+ conflicts = restic
+ options = !strip
+ source = restic-git::git+https://github.com/restic/restic
+ md5sums = SKIP
+
+pkgname = restic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ab5853efaa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Florian Daniel <fd@noxa.de>
+# Contributor: Eldar Tsraev <elts@culab.org>
+# Contributor: Andreas Guth <andreas.guth@rwth-aachen.de>
+# Contributor: Alexander Neumann <alexander@bumpern.de>
+options=(!strip)
+pkgname=restic-git
+pkgver=r702.c143f8c
+pkgrel=1
+pkgdesc="restic is a program that does backups right."
+arch=('i686' 'x86_64')
+url="https://github.com/restic/restic"
+license=('BSD')
+depends=('glibc')
+makedepends=('git' 'go>=1.3')
+provides=('restic')
+conflicts=('restic')
+source=("${pkgname}::git+https://github.com/restic/restic")
+md5sums=('SKIP')
+
+importpath='github.com/restic/restic'
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)";
+}
+
+build() {
+ cd "$pkgname"
+ go run build.go
+}
+
+package() {
+ install -Dm755 "$pkgname/restic" "$pkgdir/usr/bin/restic"
+ install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgname/README.md" "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+# vim:set ts=2 sw=2 et: