summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdis Durakovic2024-03-11 12:58:20 +0100
committerAdis Durakovic2024-03-11 12:58:20 +0100
commit675a0a72ea4a672fa5f57528b08ff147ee2ed954 (patch)
treee504263354fbb3928285aefd5e2c2f10e43ce899
downloadaur-675a0a72ea4a672fa5f57528b08ff147ee2ed954.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD51
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bf0449983dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = resticity
+ pkgdesc = A frontend for restic
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/ad-on-is/resticity
+ arch = any
+ license = GPL3
+ depends = go
+ depends = nodejs
+ depends = restic
+ depends = webkit2gtk
+ provides = resticity
+ source = https://github.com/ad-on-is/resticity/archive/refs/tags/1.0.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = resticity
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94eebd79dccb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Adis Durakovic <aur@mail.adisdurakovic.com>
+pkgname=resticity
+pkgver=1.0.1
+pkgrel=1
+epoch=
+pkgdesc="A frontend for restic"
+arch=("any")
+url="https://github.com/ad-on-is/resticity"
+license=('GPL3')
+groups=()
+depends=(go nodejs restic webkit2gtk)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(resticity)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+noextract=()
+sha256sums=("SKIP")
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ export GOPATH=/tmp/go
+ export GOBIN=/tmp/go/bin
+ go install github.com/wailsapp/wails/v2/cmd/wails@latest
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export GOPATH=/tmp/go
+ export GOBIN=/tmp/go/bin
+ /tmp/go/bin/wails build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 --no-target-directory "build/bin/resticity" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 --no-target-directory "packaging/resticity.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname}.png"
+ install -Dm755 --no-target-directory "packaging/resticity.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+} \ No newline at end of file