summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Release Action2024-03-15 12:10:17 +0000
committerAUR Release Action2024-03-15 12:10:17 +0000
commit6b3d74a56771c9974232cdfac1410dbb786ef134 (patch)
tree018eec5d8349233220d400730f5cfb9fa77e8eb1
parent675a0a72ea4a672fa5f57528b08ff147ee2ed954 (diff)
downloadaur-6b3d74a56771c9974232cdfac1410dbb786ef134.tar.gz
Bump to 1.0.12
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bf0449983dc..fbe219802dde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = resticity
pkgdesc = A frontend for restic
- pkgver = 1.0.1
+ pkgver = 1.0.12
pkgrel = 1
url = https://github.com/ad-on-is/resticity
arch = any
license = GPL3
depends = go
depends = nodejs
+ depends = npm
+ depends = pnpm
depends = restic
depends = webkit2gtk
provides = resticity
- source = https://github.com/ad-on-is/resticity/archive/refs/tags/1.0.1.tar.gz
- sha256sums = SKIP
+ source = https://github.com/ad-on-is/resticity/archive/refs/tags/1.0.12.tar.gz
+ sha256sums = c098dbf960efae165ca3e0579032d0c731c45775328d4807e6cef5478b7c3656
pkgname = resticity
diff --git a/PKGBUILD b/PKGBUILD
index 94eebd79dccb..9b5c164017df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adis Durakovic <aur@mail.adisdurakovic.com>
pkgname=resticity
-pkgver=1.0.1
+pkgver=1.0.12
pkgrel=1
epoch=
pkgdesc="A frontend for restic"
@@ -8,7 +8,7 @@ arch=("any")
url="https://github.com/ad-on-is/resticity"
license=('GPL3')
groups=()
-depends=(go nodejs restic webkit2gtk)
+depends=(go nodejs npm pnpm restic webkit2gtk)
makedepends=()
checkdepends=()
optdepends=()
@@ -21,7 +21,7 @@ install=
changelog=
source=("$url/archive/refs/tags/$pkgver.tar.gz")
noextract=()
-sha256sums=("SKIP")
+sha256sums=('c098dbf960efae165ca3e0579032d0c731c45775328d4807e6cef5478b7c3656')
validpgpkeys=()
prepare() {
@@ -35,7 +35,8 @@ build() {
cd "$pkgname-$pkgver"
export GOPATH=/tmp/go
export GOBIN=/tmp/go/bin
- /tmp/go/bin/wails build
+ export PATH=$GOBIN:$PATH
+ ./build.sh desktop $pkgver
}
check() {
@@ -48,4 +49,4 @@ package() {
install -Dm755 --no-target-directory "build/bin/resticity" "${pkgdir}/usr/bin/${pkgname}"
install -Dm755 --no-target-directory "packaging/resticity.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname}.png"
install -Dm755 --no-target-directory "packaging/resticity.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
-} \ No newline at end of file
+}