summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-05-26 18:41:56 +0200
committerNicolas Iooss2018-05-26 18:41:56 +0200
commit0bc6477063969d72138cb6eb3d115e16b68b94fe (patch)
tree1ab323594dbfbbc386b7d2f1b639cbf2d81c1603
parentbb58685661935d2e5b5dcc0bbd255b256ecea302 (diff)
downloadaur-0bc6477063969d72138cb6eb3d115e16b68b94fe.tar.gz
restorecond 2.8-1 update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2bdbabdc70f..8aacb16ef250 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = restorecond
pkgdesc = SELinux restorecon daemon
- pkgver = 2.7
+ pkgver = 2.8
pkgrel = 1
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
@@ -10,8 +10,8 @@ pkgbase = restorecond
depends = dbus-glib
depends = libselinux>=2.7
conflicts = policycoreutils<2.7
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/restorecond-2.7.tar.gz
- sha256sums = cb8e0a8d706cb2c1f105125f3514dffffefcbcfb49199183a7f91ab0bdf1f24d
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/restorecond-2.8.tar.gz
+ sha256sums = 323cab1128e5308cd85fea0e5c98e3c8973e1ada0b659f2fce76187e192271bf
pkgname = restorecond
diff --git a/PKGBUILD b/PKGBUILD
index a987b93bf838..a8c5ef92d3c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgname=restorecond
-pkgver=2.7
+pkgver=2.8
pkgrel=1
pkgdesc="SELinux restorecon daemon"
arch=('i686' 'x86_64')
@@ -10,19 +13,17 @@ license=('GPL2')
groups=('selinux')
depends=('dbus-glib' 'libselinux>=2.7')
conflicts=('policycoreutils<2.7')
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('cb8e0a8d706cb2c1f105125f3514dffffefcbcfb49199183a7f91ab0bdf1f24d')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('323cab1128e5308cd85fea0e5c98e3c8973e1ada0b659f2fce76187e192271bf')
build() {
cd "${pkgname}-${pkgver}"
-
make
}
package() {
cd "${pkgname}-${pkgver}"
-
- make DESTDIR="${pkgdir}" SBINDIR="${pkgdir}/usr/bin" install
+ make DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
# Remove restorecond init script
rm -rf "${pkgdir}/etc/rc.d"