summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-11 13:56:40 +0200
committerNicolas Iooss2017-08-11 13:56:40 +0200
commit2a89134db13710cb432eb89d08705a312d0dbe90 (patch)
treea132a087e067abd25b6c73a9bcc9d8d86a33270d
downloadaur-2a89134db13710cb432eb89d08705a312d0dbe90.tar.gz
Create restorecond package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afdd68296909
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = restorecond
+ pkgdesc = sandboxing tool for SELinux
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://github.com/SELinuxProject/selinux/wiki
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL2
+ depends = dbus-glib
+ depends = libselinux>=2.7
+ conflicts = policycoreutils<2.7
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/restorecond-2.7.tar.gz
+ sha256sums = cb8e0a8d706cb2c1f105125f3514dffffefcbcfb49199183a7f91ab0bdf1f24d
+
+pkgname = restorecond
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c02a4e75ff6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=restorecond
+pkgver=2.7
+pkgrel=1
+pkgdesc="sandboxing tool for SELinux"
+arch=('i686' 'x86_64')
+url='https://github.com/SELinuxProject/selinux/wiki'
+license=('GPL2')
+groups=('selinux')
+depends=('dbus-glib' 'libselinux>=2.7')
+conflicts=('policycoreutils<2.7')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('cb8e0a8d706cb2c1f105125f3514dffffefcbcfb49199183a7f91ab0bdf1f24d')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" SBINDIR="${pkgdir}/usr/bin" install
+
+ # Remove restorecond init script
+ rm -rf "${pkgdir}/etc/rc.d"
+}