summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrustin Lee2023-11-08 15:31:27 +0900
committerTrustin Lee2023-11-08 15:31:27 +0900
commitfe448c7882a84c28bfe3a6b363735238b2e4be8c (patch)
treeeb7911cd832ce9ddcbcfe8905b58628e025599bf
parentb272a0bcfcdb98e160a5e310fd95a698089b7482 (diff)
downloadaur-fe448c7882a84c28bfe3a6b363735238b2e4be8c.tar.gz
Add `--no-sandbox` flag / Fix AppImage URL / Add .gitignore
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..004daa9050b2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.AppImage
+/*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index b3ada2dc9698..57392792c59d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Arnaud Dovi <mr.dovi@gmail.com>
+# Maintainer: Trustin Lee <t@motd.kr>
+# Former Maintainer: Arnaud Dovi <mr.dovi@gmail.com>
pkgname=restream-chat
pkgver=2.5.4
-pkgrel=1
+pkgrel=2
pkgdesc='Keep your streaming chats in one place by Restream.io'
arch=('x86_64')
url='https://restream.io/chat'
@@ -37,7 +38,7 @@ makedepends=(
_srcname="squashfs-root"
_pkgname="Restream+Chat-${pkgver}-beta.AppImage"
source=(
- "https://s3.eu-central-1.amazonaws.com/restream-chat-client/${_pkgname}"
+ "https://chat-client.restream.io/${_pkgname}"
)
sha512sums=(
'0bab803e1904c38758816f28e4cf1146a6dd9b4344f972cf88aa537d5ca3b7d9e90e8349804b5c3d411d23c88e82c7b376eb926be163ebb0cbb8fa367b6bd594'
@@ -85,6 +86,6 @@ package() {
cp restream-chat.png "$pkgdir"/usr/share/pixmaps/restream-chat.png
echo -e "${_prefix}Setting up desktop shortcuts"
- sed -e "s|Exec=AppRun|Exec=restream-chat|" -i restream-chat.desktop
+ sed -e "s|Exec=AppRun|Exec=restream-chat --no-sandbox|" -i restream-chat.desktop
install -Dm 644 restream-chat.desktop -t "$pkgdir"/usr/share/applications
}