summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:07:11 +0200
committerAndrzej Giniewicz2015-07-07 21:07:11 +0200
commit03158102d4fe1d4352df399c5f75990a6570fcc8 (patch)
tree53d2dd123d02a9b8ba7565196599c4f5bb6f9acd
downloadaur-03158102d4fe1d4352df399c5f75990a6570fcc8.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec207c322ac0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = restview
+ pkgdesc = A viewer for ReStructuredText documents that renders them on the fly.
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = http://mg.pov.lt/restview/
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-docutils
+ depends = python-pygments
+ depends = python-readme
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/r/restview/restview-2.4.0.tar.gz
+ sha256sums = 52eed1a9ce2bc31d6b4269c8c4ba8c5c1cf7c989b465e9a62bfa6357fc0da965
+
+pkgname = restview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6af68ef59308
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Christopher Arndt <chris@chrisarndt.de>
+
+pkgname=restview
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="A viewer for ReStructuredText documents that renders them on the fly."
+arch=(any)
+url="http://mg.pov.lt/restview/"
+license=('GPL')
+depends=('python-docutils' 'python-pygments' 'python-readme')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=(http://pypi.python.org/packages/source/r/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('52eed1a9ce2bc31d6b4269c8c4ba8c5c1cf7c989b465e9a62bfa6357fc0da965')
+
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ python setup.py install --root="${pkgdir}"/ --optimize=1
+}
+