summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcelogeek2021-09-08 20:13:46 +0200
committercelogeek2021-09-08 20:13:46 +0200
commit9c774fbc81eb8f8913b1e7d10eec31c528673575 (patch)
tree9048f2cf6583a30b21a2529bab2abdc2236639d4
parente462f5ce5ad121f5045a43d4abb5c43a1989ad40 (diff)
downloadaur-9c774fbc81eb8f8913b1e7d10eec31c528673575.tar.gz
fix node issue
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--fix_node_limit.patch10
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 597817f948dc..582b24bec40a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rethinkdb
pkgdesc = Distributed NoSQL database for realtime applications
pkgver = 2.4.1
- pkgrel = 4
+ pkgrel = 5
url = https://www.rethinkdb.com
install = rethinkdb.install
arch = x86_64
@@ -23,6 +23,7 @@ pkgbase = rethinkdb
source = rethinkdb.tmpfiles.d
source = mksnapshot_crash_fix.patch
source = v8_g++7_build_fix.patch::https://github.com/nodejs/node/commit/66c1197f3aefd5b9f36533e6b617f2046acc2c0f.patch
+ source = fix_node_limit.patch
sha512sums = SKIP
sha512sums = a298232f6393735f2d459eb23f78089dd7eb1bae4907dfe61b286ceb8f93d3131c2dd45f09643089d00e2a4bef0f35739c9c8984f88b34c0ab515793f38eda46
sha512sums = d0e86e86010fafcfdad7a58fe9ed9e93deefb1ab803aa283f60cccaf7a0ee11990c59b9ab01872b1c97b08418d7b53064e938b428e50a310442b32aa385277d9
@@ -30,5 +31,6 @@ pkgbase = rethinkdb
sha512sums = 112bc0f9ecfdfae6efba5d8cc3f773085b3f345d33d350188dc70609c425e6c656a0a3069ae5c66cdc684a94fd442e990a88c0ca8d1875f085f660c76c3d7250
sha512sums = 8deea735b2c7b6fc0221a49e818d4347869330fa9e35a94c15d54f7bc64ac0b8a573906fea6cc64c05a177f3065c96d8b4d0e2a3724b6137d7f12ba7a7b419f7
sha512sums = 346020fea3e10628c687dd89fc2d9aec97e1b6734fd83828d390b4187c96c085a6e99efedb8b2f87491a4c1237de06c73aee0d0671c259935eedaddcf7f505f1
+ sha512sums = 891699ec693e2c2cd96c6ae019f1353098cea206ac5e826e8326177285aa8130d0720d2818c941d61045446449246f462bdb39d1f82387019bad39f95a6076fa
pkgname = rethinkdb
diff --git a/PKGBUILD b/PKGBUILD
index dae5045f1a1b..525b4f1953f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=rethinkdb
pkgver=2.4.1
_node=6.11.0
-pkgrel=4
+pkgrel=5
pkgdesc='Distributed NoSQL database for realtime applications'
arch=(x86_64)
url=https://www.rethinkdb.com
@@ -25,6 +25,7 @@ source=(
rethinkdb.tmpfiles.d
mksnapshot_crash_fix.patch
v8_g++7_build_fix.patch::https://github.com/nodejs/node/commit/66c1197f3aefd5b9f36533e6b617f2046acc2c0f.patch
+ fix_node_limit.patch
)
noextract=(node-v$_node.tar.gz)
sha512sums=('SKIP'
@@ -33,7 +34,8 @@ sha512sums=('SKIP'
'cab680a7e765e0a844b72ab3a57f19f3268d9a717bbe19230bd79537f0424179a56037c368326d2173a4a9cde075a67c85ce9b5a32733afb7d44806df1eac0ac'
'112bc0f9ecfdfae6efba5d8cc3f773085b3f345d33d350188dc70609c425e6c656a0a3069ae5c66cdc684a94fd442e990a88c0ca8d1875f085f660c76c3d7250'
'8deea735b2c7b6fc0221a49e818d4347869330fa9e35a94c15d54f7bc64ac0b8a573906fea6cc64c05a177f3065c96d8b4d0e2a3724b6137d7f12ba7a7b419f7'
- '346020fea3e10628c687dd89fc2d9aec97e1b6734fd83828d390b4187c96c085a6e99efedb8b2f87491a4c1237de06c73aee0d0671c259935eedaddcf7f505f1')
+ '346020fea3e10628c687dd89fc2d9aec97e1b6734fd83828d390b4187c96c085a6e99efedb8b2f87491a4c1237de06c73aee0d0671c259935eedaddcf7f505f1'
+ '891699ec693e2c2cd96c6ae019f1353098cea206ac5e826e8326177285aa8130d0720d2818c941d61045446449246f462bdb39d1f82387019bad39f95a6076fa')
prepare() {
# There are a ton of hard dependencies on Python 2
@@ -68,6 +70,7 @@ prepare() {
mv node{-v,_}$_node
cd node_$_node
patch -p1 < "$srcdir"/v8_g++7_build_fix.patch
+ patch -p0 < "$srcdir"/fix_node_limit.patch
fi
}
diff --git a/fix_node_limit.patch b/fix_node_limit.patch
new file mode 100644
index 000000000000..8c44f4e81775
--- /dev/null
+++ b/fix_node_limit.patch
@@ -0,0 +1,10 @@
+--- deps/v8_inspector/third_party/v8_inspector/platform/v8_inspector/String16STL.cpp.old 2021-09-08 18:09:36.288899969 +0200
++++ deps/v8_inspector/third_party/v8_inspector/platform/v8_inspector/String16STL.cpp 2021-09-08 18:10:06.528708959 +0200
+@@ -4,6 +4,7 @@
+
+ #include "platform/inspector_protocol/InspectorProtocol.h"
+
++#include <limits>
+ #include <algorithm>
+ #include <cctype>
+ #include <cstdio>