summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Griffis2015-10-21 07:46:51 -0400
committerPatrick Griffis2015-10-21 07:46:51 -0400
commit0a3f45a1cfeafe671da188877284ee1ca7696b01 (patch)
treeb81b13b91f5cb32bd903e72b30149e8076df27a0
downloadaur-0a3f45a1cfeafe671da188877284ee1ca7696b01.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b104b176ac3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = retro-plugins-snes
+ pkgdesc = SNES plugin for RetroGobject
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/Kekun/retro-plugins-snes
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ source = https://github.com/Kekun/retro-plugins-snes/releases/download/0.4/retro-plugins-snes-0.4.tar.gz
+ sha256sums = 7f56f48a4db567edd0a573ef0ee68c30dc6f051c958895c9f258b352fcea3164
+
+pkgname = retro-plugins-snes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ede0d1717491
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: TingPing <tingping@tingping.se>
+
+pkgname=retro-plugins-snes
+pkgver=0.4
+pkgrel=1
+pkgdesc='SNES plugin for RetroGobject'
+arch=('i686' 'x86_64')
+license=('GPL3')
+url='https://github.com/Kekun/retro-plugins-snes'
+source=("https://github.com/Kekun/retro-plugins-snes/releases/download/${pkgver}/retro-plugins-snes-${pkgver}.tar.gz")
+sha256sums=('7f56f48a4db567edd0a573ef0ee68c30dc6f051c958895c9f258b352fcea3164')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ DESTDIR="$pkgdir" make install
+}