summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprofessorkaos642016-09-12 22:58:20 -0400
committerprofessorkaos642016-09-12 22:59:35 -0400
commit482a1a63d44a59f8ff8e4b52c73d8daceae1689f (patch)
tree29bac6142d981030339649e0617ba22f90bfa87c
parentd77efff8da3602b31ef80806a242998274005518 (diff)
downloadaur-482a1a63d44a59f8ff8e4b52c73d8daceae1689f.tar.gz
leave core suggest to user's devices
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--retroarch-git.install11
3 files changed, 23 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 002763d1f724..8ae40bf67476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Sun Sep 11 14:30:31 UTC 2016
pkgbase = retroarch-git
pkgdesc = Reference frontend for the libretro API (Git-latest)
- pkgver = 1.3.6.r1096.51b0e61
+ pkgver = 1.3.6.r1142.337a0aa
pkgrel = 1
url = http://www.libretro.com/
+ install = retroarch-git.install
arch = i686
arch = x86_64
groups = libretro
@@ -39,21 +38,11 @@ pkgbase = retroarch-git
depends = libswscale.so
depends = libudev.so
depends = nvidia-cg-toolkit
- optdepends = libretro-desmume: Nintendo DS core
- optdepends = libretro-gambatte: Nintendo Game Boy/Game Boy Color core
- optdepends = libretro-genesis-plus: Sega Master System/Genesis/Game Gear/CD/32X core
- optdepends = libretro-mgba: Nintendo Game Boy Advance core
- optdepends = libretro-mupen64plus: Nintendo 64 core
- optdepends = libretro-nestopia: Nintendo Entertainment System core
- optdepends = libretro-pcsx-rearmed: Sony PlayStation core
- optdepends = libretro-reicast: Sega Dreamcast core
- optdepends = libretro-snes9x: Super Nintendo Entertainment System core
- optdepends = libretro-yabause: Sega Saturn core
optdepends = libretro-overlays: Collection of overlays
optdepends = libretro-shaders: Collection of shaders
optdepends = retroarch-assets-xmb: XMB menu assets
optdepends = retroarch-autoconfig-udev: udev joypad autoconfig
- optdepends = xdg-utils-git
+ optdepends = xdg-utils-git: Includes updated screensaver suspend fixes
provides = retroarch
conflicts = retroarch
backup = etc/retroarch.cfg
diff --git a/PKGBUILD b/PKGBUILD
index 695acee79cd9..c03a24071e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
# Maintainer: Michael DeGuzis <mdeguzis@gmail.com>
+# Generate new listing of cores:
+# pacaur -s libretro | sed 's/aur\///' | sed 'N;s/\n/ /' | awk '{print $1}'
# This package tracks the latest source code on GitHub
# Clone specific tags:
@@ -8,7 +10,7 @@
# 'git+https://github.com/KhronosGroup/SPIRV-Cross.git#commit=5c24d99')
pkgname=retroarch-git
-pkgver=1.3.6.r1096.51b0e61
+pkgver=1.3.6.r1142.337a0aa
pkgrel=1
#epoch=1
git_name=RetroArch
@@ -26,21 +28,12 @@ depends=('alsa-lib' 'gcc-libs' 'glibc' 'libdrm' 'libgl' 'libpulse' 'libusb'
'libfreetype.so' 'libswresample.so' 'libswscale.so' 'libudev.so'
'nvidia-cg-toolkit')
makedepends=('git' 'vulkan-icd-loader')
-optdepends=('libretro-desmume: Nintendo DS core'
- 'libretro-gambatte: Nintendo Game Boy/Game Boy Color core'
- 'libretro-genesis-plus: Sega Master System/Genesis/Game Gear/CD/32X core'
- 'libretro-mgba: Nintendo Game Boy Advance core'
- 'libretro-mupen64plus: Nintendo 64 core'
- 'libretro-nestopia: Nintendo Entertainment System core'
- 'libretro-pcsx-rearmed: Sony PlayStation core'
- 'libretro-reicast: Sega Dreamcast core'
- 'libretro-snes9x: Super Nintendo Entertainment System core'
- 'libretro-yabause: Sega Saturn core'
- 'libretro-overlays: Collection of overlays'
- 'libretro-shaders: Collection of shaders'
- 'retroarch-assets-xmb: XMB menu assets'
- 'retroarch-autoconfig-udev: udev joypad autoconfig'
- 'xdg-utils-git')
+install=$pkgname.install
+optdepends=('libretro-overlays: Collection of overlays'
+ 'libretro-shaders: Collection of shaders'
+ 'retroarch-assets-xmb: XMB menu assets'
+ 'retroarch-autoconfig-udev: udev joypad autoconfig'
+ 'xdg-utils-git: Includes updated screensaver suspend fixes')
backup=('etc/retroarch.cfg')
source=('git+https://github.com/libretro/RetroArch.git'
'git+https://github.com/KhronosGroup/glslang.git'
diff --git a/retroarch-git.install b/retroarch-git.install
new file mode 100644
index 000000000000..7cd1b4171d9c
--- /dev/null
+++ b/retroarch-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat <<- EOF
+ :: You can find a list of libretro cores by searching
+ :: "libretro" in the Arch Linux User Repository.
+ :: e.g. 'pacaur -s libretro'
+ EOF
+}
+
+post_upgrade() {
+ post_install $1
+}