summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprofessorkaos642016-09-20 10:58:06 -0400
committerprofessorkaos642016-09-20 10:58:06 -0400
commit6b5228f20fd3a956db3e6fda5391926d6b4e471d (patch)
treeb84e76a42856d60ba87b9552bfb6087632cb4a39
parentb68a1757a242b7c1dc99f2270c5115fec8eed1b2 (diff)
downloadaur-6b5228f20fd3a956db3e6fda5391926d6b4e471d.tar.gz
add default paths for cfg file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
-rw-r--r--default-paths.patch42
3 files changed, 59 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6830b6ea0709..3d0323877023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = retroarch-git
pkgdesc = Reference frontend for the libretro API (Git-latest)
- pkgver = 1.3.6.r1181.233925b
+ pkgver = 1.3.6.r1439.8095fa9
pkgrel = 1
url = http://www.libretro.com/
install = retroarch-git.install
@@ -49,9 +49,11 @@ pkgbase = retroarch-git
source = git+https://github.com/libretro/RetroArch.git
source = git+https://github.com/KhronosGroup/glslang.git
source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ source = default-paths.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 68cca008fb0123d6f9b989a0dfd361f8de2a5c3dfe3670d0d04cb661bd9aea5c
pkgname = retroarch-git
diff --git a/PKGBUILD b/PKGBUILD
index 875a38aa3ea9..0d3a2bc42e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@
# 'git+https://github.com/KhronosGroup/SPIRV-Cross.git#commit=5c24d99')
pkgname=retroarch-git
-pkgver=1.3.6.r1181.233925b
+pkgver=1.3.6.r1439.8095fa9
pkgrel=1
#epoch=1
-git_name=RetroArch
+_gitname=RetroArch
pkgdesc='Reference frontend for the libretro API (Git-latest)'
arch=('i686' 'x86_64')
conflicts=('retroarch')
@@ -37,21 +37,23 @@ optdepends=('libretro-overlays: Collection of overlays'
backup=('etc/retroarch.cfg')
source=('git+https://github.com/libretro/RetroArch.git'
'git+https://github.com/KhronosGroup/glslang.git'
- 'git+https://github.com/KhronosGroup/SPIRV-Cross.git')
+ 'git+https://github.com/KhronosGroup/SPIRV-Cross.git'
+ 'default-paths.patch')
sha256sums=('SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '68cca008fb0123d6f9b989a0dfd361f8de2a5c3dfe3670d0d04cb661bd9aea5c')
pkgver() {
- cd RetroArch
+ cd $_gitname
printf "%s" "$(git describe --first-parent --long --tags | sed 's/v//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
- cd RetroArch
+ cd $_gitname
git submodule init deps/{glslang/glslang,SPIRV-Cross}
git config submodule.glslang.url ../glslang
@@ -62,7 +64,12 @@ prepare() {
build() {
- cd RetroArch
+ cd $_gitname
+
+ # Patch retroarch.cfg for sane defaults (core path, core info, joypad autoconfig)
+ msg2 "Patching retroarch.cfg for default paths"
+ patch -p1 < $srcdir/default-paths.patch
+
./configure \
--prefix='/usr' \
--disable-jack \
diff --git a/default-paths.patch b/default-paths.patch
new file mode 100644
index 000000000000..3c7ce8b2e1fe
--- /dev/null
+++ b/default-paths.patch
@@ -0,0 +1,42 @@
+--- RetroArch.orig/retroarch.cfg 2016-09-20 10:31:42.688072700 -0400
++++ RetroArch/retroarch.cfg 2016-09-20 10:53:39.169243702 -0400
+@@ -35,10 +35,10 @@
+ # libretro_path = "/path/to/libretro.so"
+
+ # A directory for where to search for libretro core implementations.
+-# libretro_directory =
++libretro_directory = /usr/lib/libretro
+
+ # A directory for where to search for libretro core information.
+-# libretro_info_path =
++libretro_info_path = /usr/share/libretro/info
+
+ # Sets log level for libretro cores (GET_LOG_INTERFACE).
+ # If a log level issued by a libretro core is below libretro_log_level, it is ignored.
+@@ -98,7 +98,7 @@
+
+ # Assets directory. This location is queried by default when menu interfaces try to look for
+ # loadable assets, etc.
+-# assets_directory =
++assets_directory = /usr/share/libretro/assets
+
+ # Dynamic wallpapers directory. The place to store the wallpapers dynamically
+ # loaded by the menu depending on context.
+@@ -385,7 +385,7 @@
+
+ # Enable input auto-detection. Will attempt to autoconfigure
+ # joypads, Plug-and-Play style.
+-# input_autodetect_enable = true
++input_autodetect_enable = true
+
+ # Show the input descriptors set by the core instead of the
+ # default ones.
+@@ -414,7 +414,7 @@
+ # Input binds which are made explicit (input_playerN_*_btn/axis) will take priority over autoconfigs.
+ # Autoconfigs can be created with retroarch-joyconfig, manually, or with a frontend.
+ # Requires input_autodetect_enable to be enabled.
+-# joypad_autoconfig_dir =
++joypad_autoconfig_dir = /usr/share/libretro/autoconfig
+
+ # Sets which libretro device is used for a user.
+ # Devices are indentified with a number.