summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprofessorkaos642016-09-10 13:19:56 -0400
committerprofessorkaos642016-09-10 13:19:56 -0400
commitf9edd3567a23674d27ea3b4ff29e869b2dd124cd (patch)
treea831e029b099ebf69acf0cd2b084ea243626746f
parent332653c800277dde63d9bd723e6d832593d97f72 (diff)
downloadaur-f9edd3567a23674d27ea3b4ff29e869b2dd124cd.tar.gz
Update to latest commit
-rw-r--r--.SRCINFO62
-rw-r--r--PKGBUILD95
2 files changed, 119 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11615ebd9a97..965a68e323f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,64 @@
# Generated by mksrcinfo v8
-# ĵaŭ Jun 16 03:43:12 UTC 2016
+# Sat Sep 10 17:19:38 UTC 2016
pkgbase = retroarch-git
- pkgdesc = Simple frontend for the Libretro API
- pkgver = 1.3.1.r2850.4feaeae
+ pkgdesc = Reference frontend for the libretro API (Git-latest)
+ pkgver = 1.3.6.r1074.aab5fe6
pkgrel = 1
- epoch = 2
- url = http://github.com/libretro/RetroArch
+ url = http://www.libretro.com/
arch = i686
arch = x86_64
- arch = arm
- arch = armv6h
- license = GPL3
+ groups = libretro
+ license = GPL
makedepends = git
- depends = ffmpeg
- depends = jack2
+ makedepends = vulkan-icd-loader
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = glibc
+ depends = libdrm
depends = libgl
+ depends = libpulse
depends = libusb
+ depends = libx11
+ depends = libxcb
+ depends = libxext
depends = libxinerama
depends = libxkbcommon
depends = libxv
+ depends = libxxf86vm
depends = mesa
- depends = nvidia-cg-toolkit
depends = openal
- depends = python
depends = sdl2
- provides = retroarch
- conflicts = retroarch
- source = git+https://github.com/libretro/RetroArch
+ depends = wayland
+ depends = zlib
+ depends = libass.so
+ depends = libavcodec.so
+ depends = libavformat.so
+ depends = libavutil.so
+ depends = libfreetype.so
+ depends = libswresample.so
+ depends = libswscale.so
+ depends = libudev.so
+ depends = xdg-utils-git
+ optdepends = libretro-desmume: Nintendo DS core
+ optdepends = libretro-gambatte: Nintendo Game Boy/Game Boy Color core
+ optdepends = libretro-genesis-plus: Sega Master System/Genesis/Game Gear/CD/32X core
+ optdepends = libretro-mgba: Nintendo Game Boy Advance core
+ optdepends = libretro-mupen64plus: Nintendo 64 core
+ optdepends = libretro-nestopia: Nintendo Entertainment System core
+ optdepends = libretro-pcsx-rearmed: Sony PlayStation core
+ optdepends = libretro-reicast: Sega Dreamcast core
+ optdepends = libretro-snes9x: Super Nintendo Entertainment System core
+ optdepends = libretro-yabause: Sega Saturn core
+ optdepends = libretro-overlays: Collection of overlays
+ optdepends = libretro-shaders: Collection of shaders
+ optdepends = retroarch-assets-xmb: XMB menu assets
+ optdepends = retroarch-autoconfig-udev: udev joypad autoconfig
+ backup = etc/retroarch.cfg
+ source = git+https://github.com/libretro/RetroArch.git
+ source = git+https://github.com/KhronosGroup/glslang.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = retroarch-git
diff --git a/PKGBUILD b/PKGBUILD
index 269236ffec6d..112c397684cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,93 @@
-# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+# Maintainer: Michael DeGuzis <mdeguzis@gmail.com>
+# This package tracks the latest source code on GitHub
+# Clone specific tags:
+
+# Cloning specific tags:
+#source=("git+https://github.com/libretro/RetroArch.git#tag=v${pkgver}"
+# 'git+https://github.com/KhronosGroup/glslang.git#commit=a4a4d5e'
+# 'git+https://github.com/KhronosGroup/SPIRV-Cross.git#commit=5c24d99')
pkgname=retroarch-git
-_gitname=RetroArch
-epoch=2
-pkgver=1.3.1.r2850.4feaeae
+pkgver=1.3.6.r1074.aab5fe6
pkgrel=1
-pkgdesc="Simple frontend for the Libretro API"
-arch=('i686' 'x86_64' 'arm' 'armv6h')
-url="http://github.com/libretro/RetroArch"
-license=('GPL3')
-depends=('ffmpeg' 'jack2' 'libgl' 'libusb' 'libxinerama' 'libxkbcommon'
- 'libxv' 'mesa' 'nvidia-cg-toolkit' 'openal' 'python' 'sdl2')
-makedepends=('git')
-provides=('retroarch')
-conflicts=('retroarch')
-source=("git+https://github.com/libretro/$_gitname")
-sha256sums=('SKIP')
+#epoch=1
+git_name=RetroArch
+pkgdesc='Reference frontend for the libretro API (Git-latest)'
+arch=('i686' 'x86_64')
+url='http://www.libretro.com/'
+license=('GPL')
+groups=('libretro')
+depends=('alsa-lib' 'gcc-libs' 'glibc' 'libdrm' 'libgl' 'libpulse' 'libusb'
+ 'libx11' 'libxcb' 'libxext' 'libxinerama' 'libxkbcommon' 'libxv'
+ 'libxxf86vm' 'mesa' 'openal' 'sdl2' 'wayland' 'zlib'
+ 'libass.so' 'libavcodec.so' 'libavformat.so' 'libavutil.so'
+ 'libfreetype.so' 'libswresample.so' 'libswscale.so' 'libudev.so'
+ 'xdg-utils-git')
+makedepends=('git' 'vulkan-icd-loader')
+optdepends=('libretro-desmume: Nintendo DS core'
+ 'libretro-gambatte: Nintendo Game Boy/Game Boy Color core'
+ 'libretro-genesis-plus: Sega Master System/Genesis/Game Gear/CD/32X core'
+ 'libretro-mgba: Nintendo Game Boy Advance core'
+ 'libretro-mupen64plus: Nintendo 64 core'
+ 'libretro-nestopia: Nintendo Entertainment System core'
+ 'libretro-pcsx-rearmed: Sony PlayStation core'
+ 'libretro-reicast: Sega Dreamcast core'
+ 'libretro-snes9x: Super Nintendo Entertainment System core'
+ 'libretro-yabause: Sega Saturn core'
+ 'libretro-overlays: Collection of overlays'
+ 'libretro-shaders: Collection of shaders'
+ 'retroarch-assets-xmb: XMB menu assets'
+ 'retroarch-autoconfig-udev: udev joypad autoconfig')
+backup=('etc/retroarch.cfg')
+source=('git+https://github.com/libretro/RetroArch.git'
+ 'git+https://github.com/KhronosGroup/glslang.git'
+ 'git+https://github.com/KhronosGroup/SPIRV-Cross.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "$_gitname"
+ cd RetroArch
printf "%s" "$(git describe --first-parent --long --tags | sed 's/v//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
+
}
prepare() {
- cd "$_gitname"
- git submodule init
- git submodule update
+ cd RetroArch
+
+ git submodule init deps/{glslang/glslang,SPIRV-Cross}
+ git config submodule.glslang.url ../glslang
+ git config submodule.SPIRV-Cross.url ../SPIRV-Cross
+ git submodule update deps/{glslang/glslang,SPIRV-Cross}
+
}
build() {
- cd "$_gitname"
- ./configure --prefix=/usr
+ cd RetroArch
+ ./configure \
+ --prefix='/usr' \
+ --disable-cg \
+ --disable-jack \
+ --disable-oss
make
+ make -C gfx/video_filters
+ make -C audio/audio_filters
+
}
package() {
- cd "$_gitname"
- make install DESTDIR="$pkgdir"
+ cd RetroArch
+
+ make DESTDIR="${pkgdir}" install
+
+ install -dm 755 "${pkgdir}"/usr/lib/retroarch/filters/{audio,video}
+ install -m 644 gfx/video_filters/*.{filt,so} "${pkgdir}"/usr/lib/retroarch/filters/video/
+ install -m 644 audio/audio_filters/*.{dsp,so} "${pkgdir}"/usr/lib/retroarch/filters/audio/
+
}
+
+# vim: ts=2 sw=2 et: