summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Slipchenko2018-09-01 09:34:22 +0300
committerSergey Slipchenko2018-09-01 09:34:22 +0300
commitf9c563fda140dc5bd16ae3c7c8bc54694b3e7712 (patch)
tree514bcd12243755629993fb07d3274e696cfa260c
parent9e3ae349c37240034c0921f0b85f47c237aa7ac0 (diff)
downloadaur-f9c563fda140dc5bd16ae3c7c8bc54694b3e7712.tar.gz
Update to 1.7.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--retroarch-config.patch65
3 files changed, 43 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2a5fe7ef4ce..d8b4f1a264d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = retroarch-rbp
pkgdesc = Reference frontend for the libretro API (Raspberry Pi)
- pkgver = 1.7.3
+ pkgver = 1.7.4
pkgrel = 1.1
url = http://www.libretro.com/
arch = armv7h
groups = libretro
license = GPL
+ makedepends = git
makedepends = vulkan-icd-loader
depends = alsa-lib
depends = gcc-libs
@@ -43,10 +44,10 @@ pkgbase = retroarch-rbp
provides = retroarch
conflicts = retroarch
backup = etc/retroarch.cfg
- source = retroarch-1.7.3.tar.gz::https://github.com/libretro/RetroArch/archive/v1.7.3.tar.gz
+ source = git+https://github.com/libretro/RetroArch.git#tag=v1.7.4
source = retroarch-config.patch
- sha256sums = a60c2244609bb87cdb56dd8e1020c3be757569b5246141328804ebc5574327ea
- sha256sums = 14f07b31d6bdb049dad62dd12597c292b8d2df5cb2803d15de00a7597d3081fd
+ sha256sums = SKIP
+ sha256sums = d79c542c126b74a1b221fcc1acbe053b95f76c6c9a6ccefd10b8f459ceee94dd
pkgname = retroarch-rbp
diff --git a/PKGBUILD b/PKGBUILD
index 71afbbcc37b2..f27f42882ece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
buildarch=4
pkgname=retroarch-rbp
-pkgver=1.7.3
+pkgver=1.7.4
pkgrel=1.1
pkgdesc='Reference frontend for the libretro API (Raspberry Pi)'
arch=('armv7h')
@@ -30,25 +30,25 @@ depends=('alsa-lib' 'gcc-libs' 'glibc' 'libdrm' 'libgl' 'libpulse' 'libx11'
'libass.so' 'libavcodec.so' 'libavformat.so' 'libavutil.so'
'libfreetype.so' 'libswresample.so' 'libswscale.so' 'libudev.so'
'libusb-1.0.so')
-makedepends=('vulkan-icd-loader')
+makedepends=('git' 'vulkan-icd-loader')
optdepends=('libretro-overlays: Collection of overlays'
'libretro-shaders: Collection of shaders'
'python: retroarch-cg2glsl'
'retroarch-assets-xmb: XMB menu assets')
backup=('etc/retroarch.cfg')
-source=("retroarch-${pkgver}.tar.gz::https://github.com/libretro/RetroArch/archive/v${pkgver}.tar.gz"
+source=("git+https://github.com/libretro/RetroArch.git#tag=v${pkgver}"
'retroarch-config.patch')
-sha256sums=('a60c2244609bb87cdb56dd8e1020c3be757569b5246141328804ebc5574327ea'
- '14f07b31d6bdb049dad62dd12597c292b8d2df5cb2803d15de00a7597d3081fd')
+sha256sums=('SKIP'
+ 'd79c542c126b74a1b221fcc1acbe053b95f76c6c9a6ccefd10b8f459ceee94dd')
prepare() {
- cd RetroArch-${pkgver}
+ cd RetroArch
- patch -Np0 -i ../retroarch-config.patch
+ #patch -Np0 -i ../retroarch-config.patch
}
build() {
- cd RetroArch-${pkgver}
+ cd RetroArch
export PKG_CONFIG_PATH="/opt/vc/lib/pkgconfig:$PKG_CONFIG_PATH"
@@ -69,7 +69,7 @@ build() {
}
package() {
- cd RetroArch-${pkgver}
+ cd RetroArch
make DESTDIR="${pkgdir}" install
diff --git a/retroarch-config.patch b/retroarch-config.patch
index 4ef1f381bd72..83445166b582 100644
--- a/retroarch-config.patch
+++ b/retroarch-config.patch
@@ -1,19 +1,16 @@
---- retroarch.cfg.orig 2017-11-21 16:40:48.000000000 +0100
-+++ retroarch.cfg 2017-12-22 21:37:14.020611669 +0100
-@@ -41,10 +41,10 @@
- # libretro_path = "/path/to/libretro.so"
-
- # A directory for where to search for libretro core implementations.
--# libretro_directory =
-+libretro_directory = /usr/lib/libretro
+diff -rupN RetroArch.orig/retroarch.cfg RetroArch/retroarch.cfg
+--- RetroArch.orig/retroarch.cfg 2018-08-31 11:42:23.948303726 +0200
++++ RetroArch/retroarch.cfg 2018-08-31 11:46:13.736652832 +0200
+@@ -621,7 +621,7 @@
+ # menu_show_online_updater = true
- # A directory for where to search for libretro core information.
--# libretro_info_path =
-+libretro_info_path = /usr/share/libretro/info
+ # If disabled, will hide the ability to update cores (and core info files) inside the menu.
+-# menu_show_core_updater = true
++menu_show_core_updater = false
- # Sets log level for libretro cores (GET_LOG_INTERFACE).
- # If a log level issued by a libretro core is below libretro_log_level, it is ignored.
-@@ -104,7 +104,7 @@
+ # If disabled, the libretro core will keep running in the background when we
+ # are in the menu.
+@@ -750,7 +750,7 @@
# Assets directory. This location is queried by default when menu interfaces try to look for
# loadable assets, etc.
@@ -22,37 +19,33 @@
# Dynamic wallpapers directory. The place to store the wallpapers dynamically
# loaded by the menu depending on context.
-@@ -235,13 +235,13 @@
- # video_shader_enable = false
+@@ -763,10 +763,10 @@
+ # rgui_browser_directory =
- # Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
--# video_shader_dir =
-+video_shader_dir = /usr/share/libretro/shaders
+ # Core directory for libretro core implementations.
+-# libretro_directory =
++libretro_directory = /usr/lib/libretro
+
+ # Core info directory for libretro core information.
+-# libretro_info_path =
++libretro_info_path = /usr/share/libretro/info
- # CPU-based video filter. Path to a dynamic library.
- # video_filter =
+ # Path to content database directory.
+ # content_database_path =
+@@ -778,13 +778,13 @@
+ # cheat_database_path =
# Defines a directory where CPU-based video filters are kept.
-# video_filter_dir =
+video_filter_dir = /usr/lib/retroarch/filters/video
- # Path to a font used for rendering messages. This path must be defined to enable fonts.
- # Do note that the _full_ path of the font is necessary!
-@@ -311,7 +311,7 @@ video_message_bgcolor_opacity = 1.0
- # audio_dsp_plugin =
-
# Directory where DSP plugins are kept.
-# audio_filter_dir =
+audio_filter_dir = /usr/lib/retroarch/filters/audio
- # Will sync (block) on audio. Recommended.
- # audio_sync = true
-@@ -662,7 +662,7 @@ video_message_bgcolor_opacity = 1.0
- # menu_show_online_updater = true
-
- # If disabled, will hide the ability to update cores (and core info files) inside the menu.
--# menu_show_core_updater = true
-+menu_show_core_updater = false
+ # Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
+-# video_shader_dir =
++ video_shader_dir = /usr/share/libretro/shaders
- # If disabled, the libretro core will keep running in the background when we
- # are in the menu.
+ # Recording output directory. Where recordings are saved.
+ # recording_output_directory =