summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2015-11-29 11:18:26 +0100
committerJulian Xhokaxhiu2015-11-29 11:18:26 +0100
commit14c8f337204d270bf75bcf8cbaef1c49359be390 (patch)
tree0dd795fcce72e146f7947cf95f0429a1ebfe88f2
parent270ce5fd8266044098f2afb8126c9b03f8cfab98 (diff)
downloadaur-14c8f337204d270bf75bcf8cbaef1c49359be390.tar.gz
Back to CFLAGS and LDFLAGS.
Add also the list of libs to be linked. Maybe this is going to help.
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 360a33f64d3a..03cfdb3df17d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,8 +28,10 @@ pkgver() {
build() {
cd "${_gitname}"
+ export CFLAGS="$CFLAGS -I/opt/vc/include"
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed} -L/opt/vc/lib/ -lGLESv2 -lEGL -lopenmaxil -lbcm_host -lvcos -lvchiq_arm -lpthread"
./configure --prefix=/usr --disable-vg --disable-opengl --disable-gles --disable-fbo --disable-egl --disable-x11 --disable-sdl --disable-sdl2 --disable-pulse --disable-oss --disable-ffmpeg --disable-freetype --enable-neon --enable-dispmanx --enable-floathard --enable-udev
- make DISPMANX_CFLAGS="-I/opt/vc/include" DISPMANX_LIBS="-L/opt/vc/lib"
+ make
}
package() {