summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2015-07-25 09:41:20 +0200
committersehraf2015-07-25 09:41:20 +0200
commit4e2d2c3292ff5b7b20c03c84c24702fa37679f75 (patch)
treef0380839f095361801a07be14876c997a9647637
parent7901f8338118bd1e43d4e2bc077a6c944fbdf9c9 (diff)
downloadaur-4e2d2c3292ff5b7b20c03c84c24702fa37679f75.tar.gz
enabled void + fixed typo
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 4 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f793bdbb19f9..15cc4435cf99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,8 @@ pkgbase = retroshare
depends = libxss
depends = libmicrohttpd
depends = sqlcipher
+ depends = speex
+ depends = opencv
depends = curl
depends = libxslt
provides = retroshare
diff --git a/PKGBUILD b/PKGBUILD
index 30e3b4933ebf..e764b6d04edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _build_nogui=true
# Set this to true to build and install the plugins
_build_feedreader=true
-_build_voip=false
+_build_voip=true
### Nothing to be changed below this line ###
@@ -37,7 +37,7 @@ sha256sums=('2320676da905de6c48b01eda611811965277ffa1d5ddbb387aa8f0414c2de050'
'70be00968f2477e368f75393f193e76f366fff2dadab869c855e92048060cf29')
# Add missing dependencies if needed
-[[ $_build_voip == true ]] && depends=(${depends[@]} 'speex' 'openvc')
+[[ $_build_voip == true ]] && depends=(${depends[@]} 'speex' 'opencv')
[[ $_build_feedreader == true ]] && depends=(${depends[@]} 'curl' 'libxslt')
_rssrcdir="retroshare06-0.6.0/src"
@@ -97,13 +97,6 @@ build() {
make
fi
- if [[ "$_build_linkscloud" == "true" ]] ; then
- msg "Compiling LinksCloud plugin..."
- cd "${_srcdir}/plugins/LinksCloud"
- $_qmake
- make
- fi
-
if [[ $_build_nogui == "true" ]] ; then
msg "Compiling retroshare-nogui..."
cd "${_srcdir}/retroshare-nogui/src"
@@ -139,11 +132,6 @@ package() {
# Plugins
- if [[ "$_build_linkscloud" == "true" ]] ; then
- install -D -m 755 \
- "${_srcdir}/plugins/LinksCloud/libLinksCloud.so" \
- "${pkgdir}/usr/lib/retroshare/extensions/libLinksCloud.so"
- fi
if [[ "$_build_voip" == "true" ]] ; then
install -D -m 755 \
"${_srcdir}/plugins/VOIP/libVOIP.so" \