summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2021-05-29 09:50:59 +0200
committersehraf2021-05-29 09:50:59 +0200
commit8697b6635bcfb6327a7c2e7749577f0c939d9df6 (patch)
treedc8eab834cf64789aefe9ab1dca68cdb3a5b01c5
parent087d8b1aacc14fd902f5a959cc788aaea3ca3f10 (diff)
downloadaur-8697b6635bcfb6327a7c2e7749577f0c939d9df6.tar.gz
fix/hacked create_directories
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--bbaad838572b5fba6109bc7d3b5c55c2c68e6cdc.patch65
-rw-r--r--fix_create_directories.patch41
4 files changed, 48 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfe2824f3855..942a7b868720 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -30,6 +30,7 @@ pkgbase = retroshare
source = openssl-894da2fb7ed5d314ee5c2fc9fd2d9b8b74111596.tar.gz::https://github.com/corvusoft/openssl-dependency/archive/894da2fb7ed5d314ee5c2fc9fd2d9b8b74111596.tar.gz
source = udp-discovery-cpp-f3a3103a6c52e5707629e8d0a7e279a7758fe845.tar.gz::https://github.com/truvorskameikin/udp-discovery-cpp/archive/f3a3103a6c52e5707629e8d0a7e279a7758fe845.tar.gz
source = fix_icon_path.patch
+ source = fix_create_directories.patch
sha256sums = c545b9249ac7dbfef72a2d636bc0f8b729c7ce05f21a54dd9284b2a387592d4a
sha256sums = e01389d3f0481458e14861ee33abc2f7aec3a382bd70e91dee495ac6e943d403
sha256sums = a4a47becc545c88724fa831617e628c66503d5ef7faf235c7c7237611230f59f
@@ -37,6 +38,7 @@ pkgbase = retroshare
sha256sums = d5e94ef0fd5aa9168080cc3c086093443964b582292c91519d391db8ac4065b4
sha256sums = ec00c4da0d43769351ff94cef81b30afe0dd1932a80ded497a338b2f2364d232
sha256sums = 724f55edb3aa5ae34abfcba341cdecf3d6f5095d1d7018de4e254ae5627c426f
+ sha256sums = 1019d25aa0f6d467fcd1e67c15acb5e11a44f97b328385b750b061decdcdf6a3
pkgname = retroshare
diff --git a/PKGBUILD b/PKGBUILD
index 13fe78d31671..b725a9c2874d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,8 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/retroshare/${pkgname}/a
"catch-${_catch_cid}.tar.gz::https://github.com/corvusoft/catch-dependency/archive/${_catch_cid}.tar.gz"
"openssl-${_openssl_cid}.tar.gz::https://github.com/corvusoft/openssl-dependency/archive/${_openssl_cid}.tar.gz"
"udp-discovery-cpp-${_udpdiscoverycpp_cid}.tar.gz::https://github.com/truvorskameikin/udp-discovery-cpp/archive/${_udpdiscoverycpp_cid}.tar.gz"
- "fix_icon_path.patch")
+ "fix_icon_path.patch"
+ "fix_create_directories.patch")
sha256sums=('c545b9249ac7dbfef72a2d636bc0f8b729c7ce05f21a54dd9284b2a387592d4a'
'e01389d3f0481458e14861ee33abc2f7aec3a382bd70e91dee495ac6e943d403'
@@ -59,7 +60,8 @@ sha256sums=('c545b9249ac7dbfef72a2d636bc0f8b729c7ce05f21a54dd9284b2a387592d4a'
'df455d92de685af7798c2e18811a5e86f95777e8c022ab9b13f3b2b3d134a16d'
'd5e94ef0fd5aa9168080cc3c086093443964b582292c91519d391db8ac4065b4'
'ec00c4da0d43769351ff94cef81b30afe0dd1932a80ded497a338b2f2364d232'
- '724f55edb3aa5ae34abfcba341cdecf3d6f5095d1d7018de4e254ae5627c426f')
+ '724f55edb3aa5ae34abfcba341cdecf3d6f5095d1d7018de4e254ae5627c426f'
+ '1019d25aa0f6d467fcd1e67c15acb5e11a44f97b328385b750b061decdcdf6a3')
# Add missing dependencies if needed
[[ "$_plugin_voip" == 'true' ]] && depends=(${depends[@]} 'ffmpeg' 'opencv3-opt')
@@ -86,6 +88,7 @@ prepare() {
cd "${srcdir}"/${pkgname}-${pkgver}
patch -p1 --ignore-whitespace -i "${srcdir}"/fix_icon_path.patch
+ patch -p1 --ignore-whitespace -i "${srcdir}"/fix_create_directories.patch
[[ "$_plugin_voip" == 'true' ]] && sed -i -e 's/PKGCONFIG += opencv/PKGCONFIG += opencv3/g' plugins/VOIP/VOIP.pro || true
diff --git a/bbaad838572b5fba6109bc7d3b5c55c2c68e6cdc.patch b/bbaad838572b5fba6109bc7d3b5c55c2c68e6cdc.patch
deleted file mode 100644
index 732984645d47..000000000000
--- a/bbaad838572b5fba6109bc7d3b5c55c2c68e6cdc.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-backport of
-
-From bbaad838572b5fba6109bc7d3b5c55c2c68e6cdc Mon Sep 17 00:00:00 2001
-From: Phenom <retrosharephenom@gmail.com>
-Date: Mon, 1 Jun 2020 13:44:43 +0200
-Subject: [PATCH] Fix build with Qt 5.15+
-
----
- retroshare-gui/src/gui/elastic/elnode.h | 8 +++++---
- .../src/gui/gxs/GxsCommentTreeWidget.cpp | 16 +++++++++-------
- retroshare-gui/src/gui/gxs/GxsIdDetails.cpp | 18 ++++++++++--------
- 3 files changed, 24 insertions(+), 18 deletions(-)
-
-diff --git a/retroshare-gui/src/gui/elastic/elnode.h b/retroshare-gui/src/gui/elastic/elnode.h
-index 1e0edd1a8..b881baed6 100644
---- a/retroshare-gui/src/gui/elastic/elnode.h
-+++ b/retroshare-gui/src/gui/elastic/elnode.h
-@@ -34,6 +34,8 @@
- #include <retroshare/rstypes.h>
- #include "graphwidget.h"
-
-+#include <QPainterPath>
-+
- class Edge;
- QT_BEGIN_NAMESPACE
- class QGraphicsSceneMouseEvent;
-diff --git a/retroshare-gui/src/gui/gxs/GxsCommentTreeWidget.cpp b/retroshare-gui/src/gui/gxs/GxsCommentTreeWidget.cpp
-index e5d714860..a3187d4d9 100644
---- a/retroshare-gui/src/gui/gxs/GxsCommentTreeWidget.cpp
-+++ b/retroshare-gui/src/gui/gxs/GxsCommentTreeWidget.cpp
-@@ -18,6 +18,14 @@
- * *
- *******************************************************************************/
-
-+#include "GxsCommentTreeWidget.h"
-+
-+#include "gui/common/FilesDefs.h"
-+#include "gui/common/RSElidedItemDelegate.h"
-+#include "gui/common/RSTreeWidgetItem.h"
-+#include "gui/gxs/GxsCreateCommentDialog.h"
-+#include "gui/gxs/GxsIdTreeWidgetItem.h"
-+
- #include <QAbstractTextDocumentLayout>
- #include <QApplication>
- #include <QClipboard>
-@@ -25,6 +33,7 @@
- #include <QMenu>
- #include <QMimeData>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QTextDocument>
-
- #include "gui/common/RSElidedItemDelegate.h"
-diff --git a/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp b/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp
-index 6168090eb..1bbab7f82 100644
---- a/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp
-+++ b/retroshare-gui/src/gui/gxs/GxsIdDetails.cpp
-@@ -31,6 +31,7 @@
-
- #include <iostream>
- #include <QPainter>
-+#include <QPainterPath>
-
- /* Images for tag icons */
- #define IMAGE_LOADING ":/images/folder-draft.png"
diff --git a/fix_create_directories.patch b/fix_create_directories.patch
new file mode 100644
index 000000000000..f57885d8842b
--- /dev/null
+++ b/fix_create_directories.patch
@@ -0,0 +1,41 @@
+diff --git a/libretroshare/src/util/rsdir.cc b/libretroshare/src/util/rsdir.cc
+index 8556b8198..0277762d8 100644
+--- a/libretroshare/src/util/rsdir.cc
++++ b/libretroshare/src/util/rsdir.cc
+@@ -528,7 +528,7 @@ bool RsDirUtil::checkCreateDirectory(const std::string& dir)
+ return true;
+ }
+
+-#if __cplusplus < 201703L
++//#if __cplusplus < 201703L
+ bool std::filesystem::create_directories(const std::string& path)
+ {
+ for( std::string::size_type lastIndex = 0; lastIndex < std::string::npos;
+@@ -544,7 +544,7 @@ bool std::filesystem::create_directories(const std::string& path)
+ }
+ return true;
+ }
+-#endif // __cplusplus < 201703L
++//#endif // __cplusplus < 201703L
+
+ std::string RsDirUtil::removeSymLinks(const std::string& path)
+ {
+diff --git a/libretroshare/src/util/rsdir.h b/libretroshare/src/util/rsdir.h
+index 50e636541..af8e59509 100644
+--- a/libretroshare/src/util/rsdir.h
++++ b/libretroshare/src/util/rsdir.h
+@@ -153,7 +153,7 @@ std::string makePath(const std::string &path1, const std::string &path2);
+ RS_SET_CONTEXT_DEBUG_LEVEL(1);
+ }
+
+-#if __cplusplus < 201703L
++//#if __cplusplus < 201703L
+ namespace std
+ {
+ namespace filesystem
+@@ -161,4 +161,4 @@ namespace filesystem
+ bool create_directories(const std::string& path);
+ }
+ }
+-#endif // __cplusplus < 201703L
++//#endif // __cplusplus < 201703L