summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2015-06-10 18:35:33 +0200
committersehraf2015-06-10 18:35:33 +0200
commitd939a7cb3524e80fb7a5f63286f96c87735b4f85 (patch)
treec505cc927cef33f5fb269339d76f7e2f76eee285
downloadaur-d939a7cb3524e80fb7a5f63286f96c87735b4f85.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD150
-rw-r--r--retroshare.desktop11
-rw-r--r--retroshare.install15
4 files changed, 206 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed917cf429e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = retroshare
+ pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
+ pkgver = 0.5.5c
+ pkgrel = 2
+ url = http://retroshare.sourceforge.net/
+ install = retroshare.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = LGPL
+ license = GPL
+ depends = qt4
+ depends = libupnp
+ depends = libgnome-keyring
+ depends = libxss
+ depends = libssh
+ depends = protobuf
+ depends = speex
+ depends = curl
+ depends = libxslt
+ source = http://sourceforge.net/projects/retroshare/files/RetroShare/0.5.5c/retroshare_0.5.5-0.7068.tar.gz
+ source = retroshare.install
+ source = retroshare.desktop
+ sha256sums = 772b0d7916137e81fc0f5ea14f0a8fa70d3d7acb701ca0b0c1c66018f2255650
+ sha256sums = 4b50547648612e9091536205402a4da9ddea9c18c0f71e5d6cd30b2226f206d9
+ sha256sums = 70be00968f2477e368f75393f193e76f366fff2dadab869c855e92048060cf29
+
+pkgname = retroshare
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0b79c0efb8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,150 @@
+# Maintainer: stqn
+# Contributor: JHeaton <jheaton at archlinux dot us>
+# Contributor: Tristero <tristero at online dot de>
+# Contributor: funkyou
+
+# Set this to true to build and install retroshare-nogui
+_build_nogui=true
+
+# Set this to true to build and install the plugins
+_build_linkscloud=true
+_build_feedreader=true
+_build_voip=true
+
+### Nothing to be changed below this line ###
+
+pkgname=retroshare
+pkgver=0.5.5c
+pkgrel=2
+pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://retroshare.sourceforge.net/"
+license=('LGPL' 'GPL')
+depends=('qt4' 'libupnp' 'libgnome-keyring' 'libxss')
+install="${pkgname}.install"
+
+source=(http://sourceforge.net/projects/retroshare/files/RetroShare/${pkgver}/retroshare_0.5.5-0.7068.tar.gz \
+ ${pkgname}.install \
+ ${pkgname}.desktop)
+
+sha256sums=('772b0d7916137e81fc0f5ea14f0a8fa70d3d7acb701ca0b0c1c66018f2255650'
+ '4b50547648612e9091536205402a4da9ddea9c18c0f71e5d6cd30b2226f206d9'
+ '70be00968f2477e368f75393f193e76f366fff2dadab869c855e92048060cf29')
+
+# Add missing dependencies if needed
+[[ $_build_nogui == true ]] && depends=(${depends[@]} 'libssh' 'protobuf')
+[[ $_build_voip == true ]] && depends=(${depends[@]} 'speex')
+[[ $_build_feedreader == true ]] && depends=(${depends[@]} 'curl' 'libxslt')
+
+_rssrcdir="retroshare-0.5.5/src"
+
+build() {
+ local _srcdir="${srcdir}/$_rssrcdir"
+ local _qmake='qmake-qt4'
+
+ msg "Compiling OpenPGP-SDK..."
+ cd "${_srcdir}/openpgpsdk/src"
+ $_qmake
+ make
+
+ msg "Compiling libbitdht..."
+ cd "${_srcdir}/libbitdht/src"
+ $_qmake
+ make
+
+ msg "Compiling libretroshare..."
+ cd "${_srcdir}/libretroshare/src"
+ $_qmake
+ make
+
+ msg "Compiling retroshare-gui..."
+ cd "${_srcdir}/retroshare-gui/src"
+ $_qmake
+ make
+
+ if [[ "$_build_voip" == "true" ]] ; then
+ msg "Compiling VOIP plugin..."
+ cd "${_srcdir}/plugins/VOIP"
+ #sed -i 's/lessThan.*/true {/' VOIP.pro
+ $_qmake
+ make
+ fi
+
+ if [[ "$_build_feedreader" == "true" ]] ; then
+ msg "Compiling FeedReader plugin..."
+ cd "${_srcdir}/plugins/FeedReader"
+ $_qmake
+ make
+ fi
+
+ if [[ "$_build_linkscloud" == "true" ]] ; then
+ msg "Compiling LinksCloud plugin..."
+ cd "${_srcdir}/plugins/LinksCloud"
+ $_qmake
+ make
+ fi
+
+ if [[ $_build_nogui == "true" ]] ; then
+ msg "Compiling retroshare-nogui..."
+ cd "${_srcdir}/rsctrl/src"
+ make
+ cd "${_srcdir}/retroshare-nogui/src"
+ #sed -i 's/pkg-config --atleast-version 0.5.4 libssh/pkg-config --atleast-version 0.5 libssh/' retroshare-nogui.pro
+ $_qmake
+ make
+ fi
+}
+
+package() {
+ local _srcdir="${srcdir}/$_rssrcdir"
+
+ # --- Install Files ---
+
+ msg "Installing files to fakeroot-environment..."
+
+ install -D -m 755 \
+ "${_srcdir}/retroshare-gui/src/RetroShare" \
+ "${pkgdir}/usr/bin/${pkgname}"
+
+ if [[ "$_build_nogui" == "true" ]] ; then
+ install -D -m 755 \
+ "${_srcdir}/retroshare-nogui/src/retroshare-nogui" \
+ "${pkgdir}/usr/bin/${pkgname}-nogui"
+ fi
+
+ # Plugins
+ if [[ "$_build_linkscloud" == "true" ]] ; then
+ install -D -m 755 \
+ "${_srcdir}/plugins/LinksCloud/libLinksCloud.so" \
+ "${pkgdir}/usr/lib/retroshare/extensions/libLinksCloud.so"
+ fi
+ if [[ "$_build_voip" == "true" ]] ; then
+ install -D -m 755 \
+ "${_srcdir}/plugins/VOIP/libVOIP.so" \
+ "${pkgdir}/usr/lib/retroshare/extensions/libVOIP.so"
+ fi
+ if [[ "$_build_feedreader" == "true" ]] ; then
+ install -D -m 755 \
+ "${_srcdir}/plugins/FeedReader/libFeedReader.so" \
+ "${pkgdir}/usr/lib/retroshare/extensions/libFeedReader.so"
+ fi
+
+ # Icons
+ install -D -m 644 \
+ "${_srcdir}/retroshare-gui/src/gui/images/retrosharelogo2.png" \
+ "${pkgdir}/usr/share/pixmaps/retroshare.png"
+
+ # Desktop File
+ install -D -m 644 \
+ "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # bdboot (needed to bootstrap the DHT)
+ install -D -m 644 \
+ "${_srcdir}/libbitdht/src/bitdht/bdboot.txt" \
+ "${pkgdir}/usr/share/RetroShare/bdboot.txt"
+
+ # Skins
+ cp -r "${_srcdir}/retroshare-gui/src/qss" "${pkgdir}/usr/share/RetroShare/"
+ #find "${pkgdir}/usr/share/RetroShare/" -depth -type d -name ".svn" -exec rm -r {} \;
+}
diff --git a/retroshare.desktop b/retroshare.desktop
new file mode 100644
index 000000000000..0c3f56180aa8
--- /dev/null
+++ b/retroshare.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=RetroShare
+GenericName=Sharing Network
+Comment=Secure Communication with Your Friends
+Icon=/usr/share/pixmaps/retroshare.png
+Exec=/usr/bin/retroshare
+Terminal=false
+StartupNotify=true
+Categories=Network;InstantMessaging;FileTransfer;Chat;Email;
diff --git a/retroshare.install b/retroshare.install
new file mode 100644
index 000000000000..e48df13610f0
--- /dev/null
+++ b/retroshare.install
@@ -0,0 +1,15 @@
+post_install() {
+ # Update Desktop DB
+ if [[ -x /usr/bin/update-desktop-database ]]; then
+ echo "Update desktop database..."
+ update-desktop-database -q ;
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}