summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2016-04-25 15:26:54 +0200
committersehraf2016-04-25 15:26:54 +0200
commit1ae7592bd840eadf2a289fbf68dacb991333002c (patch)
treee6fb09ec73523be8cf5c16a593f134da252a0b18
parentb8b504d4f131bcfea435f4dcd7349e0c50cdee21 (diff)
downloadaur-1ae7592bd840eadf2a289fbf68dacb991333002c.tar.gz
cleanup and optional clang support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD38
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38385ad25079..3d206670e13a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 5 23:37:21 UTC 2016
+# Mon Apr 25 13:25:50 UTC 2016
pkgbase = retroshare-git
pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
- pkgver = v0.6.0.r0.gccf96a3
+ pkgver = v0.6.0.r395.g0d84a55
pkgrel = 1
url = http://retroshare.sourceforge.net/
install = retroshare.install
@@ -21,6 +21,7 @@ pkgbase = retroshare-git
depends = libxss
depends = libmicrohttpd
depends = sqlcipher
+ depends = desktop-file-utils
depends = ffmpeg
depends = opencv
depends = curl
diff --git a/PKGBUILD b/PKGBUILD
index 2cbf471c8959..d2e305f3359d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,31 @@
# Maintainer: sehraf
# Contributor: stqn
-# Set this to true to build and install the plugins
+# Set this to 'true' to build and install the plugins
_build_feedreader=true
_build_voip=true
+# set this to 'true' to use clang for compiling (experimental)
+_clang=
+
### Nothing to be changed below this line ###
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.0.r0.gccf96a3
+pkgver=v0.6.0.r395.g0d84a55
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://retroshare.sourceforge.net/"
license=('GPL' 'LGPL')
-
-# qt4
-#depends=('qt4' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlcipher')
-#makedepends=('git')
-
-#qt 5
-depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlcipher')
+depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlcipher' 'desktop-file-utils')
makedepends=('git' 'qt5-tools')
-
optdepends=('tor: tor hidden node support'
'i2p: i2p hidden node support')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
install="${_pkgname}.install"
-
source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git"
'retroshare.install')
@@ -38,8 +33,13 @@ sha256sums=('SKIP'
'44ea7d8b0208e8954391184dcbb8ff94b2efc246580057a1d2b2e73ad262aad2')
# Add missing dependencies if needed
-[[ $_build_voip == true ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
-[[ $_build_feedreader == true ]] && depends=(${depends[@]} 'curl' 'libxslt')
+[[ "$_build_voip" == 'true' ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
+[[ "$_build_feedreader" == 'true' ]] && depends=(${depends[@]} 'curl' 'libxslt')
+[[ "$_clang" == 'true' ]] && makedepends=(${makedepends[@]} 'clang')
+
+# Set options for qmake
+_options=''
+[[ "$_clang" == 'true' ]] && _options='-spec linux-clang'
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -50,12 +50,8 @@ build() {
cd "${srcdir}/${_pkgname}"
# remove unwanted plugins
- if [[ "$_build_voip" != 'true' ]] ; then
- sed -i '/VOIP \\/d' plugins/plugins.pro
- fi
- if [[ "$_build_feedreader" != 'true' ]] ; then
- sed -i '/FeedReader/d' plugins/plugins.pro
- fi
+ [[ "$_build_voip" != 'true' ]] && sed -i '/VOIP \\/d' plugins/plugins.pro
+ [[ "$_build_feedreader" != 'true' ]] && sed -i '/FeedReader/d' plugins/plugins.pro
# call version scripts
cd libretroshare/src
@@ -66,8 +62,8 @@ build() {
LANG=C ./version_detail.sh
cd ../..
- # qt4: qmake-qt4 -r ...
- qmake "CONFIG-=debug" "CONFIG+=release" \
+ qmake "${_options}" \
+ CONFIG-=debug CONFIG+=release \
QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"\
RetroShare.pro