summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2021-05-29 09:40:55 +0200
committersehraf2021-05-29 09:40:55 +0200
commit4549ae816e2fe6ccf8bd0643273cae986efbbce8 (patch)
tree154c57c735015d5d9995f14cd1675fdeb2723007
parentcb31b52614882d75382aba4e3a566e1cde9045be (diff)
downloadaur-4549ae816e2fe6ccf8bd0643273cae986efbbce8.tar.gz
fix/hacked create_directories
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--fix_create_directories.patch41
3 files changed, 56 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 079daf0c0915..9adc45e318ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = retroshare-git
pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
- pkgver = v0.6.6.r8.g67c607cb3
+ pkgver = v0.6.6.r49.gd1a166df5
pkgrel = 1
url = http://retroshare.cc/
arch = i686
@@ -27,7 +27,9 @@ pkgbase = retroshare-git
provides = retroshare
conflicts = retroshare
source = retroshare::git+https://github.com/RetroShare/RetroShare.git
+ source = fix_create_directories.patch
sha256sums = SKIP
+ sha256sums = 1019d25aa0f6d467fcd1e67c15acb5e11a44f97b328385b750b061decdcdf6a3
pkgname = retroshare-git
diff --git a/PKGBUILD b/PKGBUILD
index 4cba7f53455a..c6625cfe3a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ _nativ_dialogs='true'
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.6.r8.g67c607cb3
+pkgver=v0.6.6.r49.gd1a166df5
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -42,8 +42,11 @@ optdepends=('tor: tor hidden node support'
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git")
-sha256sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git"
+ 'fix_create_directories.patch'
+)
+sha256sums=('SKIP'
+ '1019d25aa0f6d467fcd1e67c15acb5e11a44f97b328385b750b061decdcdf6a3')
# Add sql dependency
[[ "$_no_sqlcipher" == 'true' ]] && depends=(${depends[@]} 'sqlite') || depends=(${depends[@]} 'sqlcipher')
@@ -75,7 +78,6 @@ _optNativDialogs=''
if [[ "$_plugin_lua4rs" == 'true' ]] ; then
depends=(${depends[@]} 'lua')
source=(${source[@]} 'Lua4RS::git+https://github.com/RetroShare/Lua4RS.git')
- sha256sums=(${sha256sums[@]} 'SKIP')
fi
pkgver() {
@@ -83,6 +85,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ patch -p1 --ignore-whitespace -i "${srcdir}"/fix_create_directories.patch
+}
+
build() {
cd "${srcdir}/${_pkgname}"
diff --git a/fix_create_directories.patch b/fix_create_directories.patch
new file mode 100644
index 000000000000..f57885d8842b
--- /dev/null
+++ b/fix_create_directories.patch
@@ -0,0 +1,41 @@
+diff --git a/libretroshare/src/util/rsdir.cc b/libretroshare/src/util/rsdir.cc
+index 8556b8198..0277762d8 100644
+--- a/libretroshare/src/util/rsdir.cc
++++ b/libretroshare/src/util/rsdir.cc
+@@ -528,7 +528,7 @@ bool RsDirUtil::checkCreateDirectory(const std::string& dir)
+ return true;
+ }
+
+-#if __cplusplus < 201703L
++//#if __cplusplus < 201703L
+ bool std::filesystem::create_directories(const std::string& path)
+ {
+ for( std::string::size_type lastIndex = 0; lastIndex < std::string::npos;
+@@ -544,7 +544,7 @@ bool std::filesystem::create_directories(const std::string& path)
+ }
+ return true;
+ }
+-#endif // __cplusplus < 201703L
++//#endif // __cplusplus < 201703L
+
+ std::string RsDirUtil::removeSymLinks(const std::string& path)
+ {
+diff --git a/libretroshare/src/util/rsdir.h b/libretroshare/src/util/rsdir.h
+index 50e636541..af8e59509 100644
+--- a/libretroshare/src/util/rsdir.h
++++ b/libretroshare/src/util/rsdir.h
+@@ -153,7 +153,7 @@ std::string makePath(const std::string &path1, const std::string &path2);
+ RS_SET_CONTEXT_DEBUG_LEVEL(1);
+ }
+
+-#if __cplusplus < 201703L
++//#if __cplusplus < 201703L
+ namespace std
+ {
+ namespace filesystem
+@@ -161,4 +161,4 @@ namespace filesystem
+ bool create_directories(const std::string& path);
+ }
+ }
+-#endif // __cplusplus < 201703L
++//#endif // __cplusplus < 201703L