summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2018-02-25 09:25:29 +0100
committersehraf2018-02-25 09:26:55 +0100
commit4642c492ade5fa5f264f050def78b4c765f007a1 (patch)
tree7c9e05d917af534988e4c7be55f389bf4f42d161
parentbe55f934f1c70f959450ce4a02cd9fc53f2e6d9b (diff)
downloadaur-4642c492ade5fa5f264f050def78b4c765f007a1.tar.gz
0.6.4 RC2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a1c15eb22b3..925a51f15b9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 24 17:42:31 UTC 2017
+# Sun Feb 25 08:26:34 UTC 2018
pkgbase = retroshare-git
pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
- pkgver = v0.6.3.r421.g1c2d17b5c
+ pkgver = v0.6.4.RC1.r0.g31ab87c65
pkgrel = 1
url = http://retroshare.sourceforge.net/
arch = i686
@@ -19,10 +19,6 @@ pkgbase = retroshare-git
depends = libxss
depends = libmicrohttpd
depends = sqlcipher
- depends = ffmpeg
- depends = opencv
- depends = curl
- depends = libxslt
optdepends = tor: tor hidden node support
optdepends = i2p: i2p hidden node support
provides = retroshare
diff --git a/PKGBUILD b/PKGBUILD
index 80415924b7a3..95ab19561719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: stqn
# Set this to 'true' to build and install the plugins
-_plugin_feedreader=true
-_plugin_voip=true
+#_plugin_feedreader=true
+#_plugin_voip=true
# Set this to 'true' to enable auto login
#_autologin='true'
@@ -18,7 +18,7 @@ _plugin_voip=true
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.3.r421.g1c2d17b5c
+pkgver=v0.6.4.RC1.r0.g31ab87c65
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -43,8 +43,10 @@ sha256sums=('SKIP')
# Set options for qmake
_optClang=''
_optAutol=''
+_optPlugin=''
[[ "$_clang" == 'true' ]] && _optClang='-spec linux-clang CONFIG+=c++11'
[[ "$_autologin" == 'true' ]] && _optAutol='CONFIG+=rs_autologin'
+([[ "$_plugin_voip" == 'true' ]] || [[ "$_plugin_feedreader" == 'true' ]] || [[ "$_plugin_lua4rs" == 'true' ]]) && _optPlugin='CONFIG+=retroshare_plugins'
# Handle unofficial plugins
if [[ "$_plugin_lua4rs" == 'true' ]] ; then
@@ -82,9 +84,9 @@ build() {
cd ../..
qmake CONFIG-=debug CONFIG+=release \
- ${_optAutol} ${_optClang} \
- QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
- QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"\
+ ${_optAutol} ${_optClang} ${_optPlugin} \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
RetroShare.pro
make
}