summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2017-05-16 19:58:18 +0200
committersehraf2017-05-16 19:58:18 +0200
commit5f2721d4f6513f339452eb5b4363e58b97e28aa7 (patch)
tree3a16f134bf79c2b60dc0fd87061451dc3f9239de
parentb9130eedeb5ce2b42c8be3ba1de7e96e6b169c9f (diff)
downloadaur-5f2721d4f6513f339452eb5b4363e58b97e28aa7.tar.gz
Added Lua4RS
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 823ae1e80cb2..8aa897d84e79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 12 20:44:21 UTC 2017
+# Tue May 16 17:58:01 UTC 2017
pkgbase = retroshare-git
pkgdesc = Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
- pkgver = v0.6.2.r0.g733b1143b
+ pkgver = v0.6.2.r348.g86118d9de
pkgrel = 1
url = http://retroshare.sourceforge.net/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 498d48497591..183a60d3d88a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,17 @@ _build_voip=true
# Set this to 'true' to enable auto login
#_autologin='true'
-# set this to 'true' to use clang for compiling (experimental)
+# Set this to 'true' to use clang for compiling (experimental)
#_clang='true'
+# Unofficial plugins
+#_plugin_lua4rs='true'
+
### Nothing to be changed below this line ###
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.2.r0.g733b1143b
+pkgver=v0.6.2.r348.g86118d9de
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -43,6 +46,13 @@ _optAutol=''
[[ "$_clang" == 'true' ]] && _optClang='-spec linux-clang CONFIG+=c++11'
[[ "$_autologin" == 'true' ]] && _optAutol='CONFIG+=rs_autologin'
+# Handle unofficial plugins
+if [[ "$_plugin_lua4rs" == 'true' ]] ; then
+ depends=(${depends[@]} 'lua')
+ source=(${source[@]} 'Lua4RS::git+https://github.com/RetroShare/Lua4RS.git')
+ sha256sums=(${sha256sums[@]} 'SKIP')
+fi
+
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -51,6 +61,13 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
+ # Handle unofficial plugins
+ if [[ "$_plugin_lua4rs" == 'true' ]] ; then
+ [[ -d 'plugins/Lua4RS' ]] && rm -r plugins//Lua4RS
+ cp -r -l "${srcdir}/Lua4RS" plugins/
+ sed -i -e 's/SUBDIRS += \\/SUBDIRS += \\\n\t\tLua4RS \\/g' plugins/plugins.pro
+ fi
+
# remove unwanted plugins
[[ "$_build_voip" != 'true' ]] && sed -i '/VOIP \\/d' plugins/plugins.pro
[[ "$_build_feedreader" != 'true' ]] && sed -i '/FeedReader/d' plugins/plugins.pro