summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsehraf2015-08-27 17:46:09 +0200
committersehraf2015-08-27 17:46:09 +0200
commit7aa46f24ff25c845d8b600f36a008859f392790b (patch)
treed3a99229f621df1302eee91adef490ccac9d3259
parent90a31c7098eb6d386816cbb489506a8f3439f4ff (diff)
downloadaur-7aa46f24ff25c845d8b600f36a008859f392790b.tar.gz
now uses make install
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD123
-rw-r--r--retroshare.install18
3 files changed, 33 insertions, 114 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3f1913206c6..52c16410b50b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,12 +17,16 @@ pkgbase = retroshare-git
depends = libxss
depends = libmicrohttpd
depends = sqlcipher
+ depends = speex
+ depends = opencv
+ depends = curl
+ depends = libxslt
provides = retroshare
conflicts = retroshare
source = retroshare::git+https://github.com/RetroShare/RetroShare.git
source = retroshare.install
sha256sums = SKIP
- sha256sums = 47c23238cbfabb6f07b6a25666ee5941243176360ca28ec31378d94e87326ec1
+ sha256sums = 44ea7d8b0208e8954391184dcbb8ff94b2efc246580057a1d2b2e73ad262aad2
pkgname = retroshare-git
diff --git a/PKGBUILD b/PKGBUILD
index e27ee86c2369..daadb5901ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,6 @@
# Maintainer: sehraf
# Contributor: stqn
-# Set this to true to build and install retroshare-nogui
-_build_nogui=true
-
# Set this to true to build and install the plugins
_build_feedreader=true
_build_voip=true
@@ -30,7 +27,7 @@ source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git"
'retroshare.install')
sha256sums=('SKIP'
- '47c23238cbfabb6f07b6a25666ee5941243176360ca28ec31378d94e87326ec1')
+ '44ea7d8b0208e8954391184dcbb8ff94b2efc246580057a1d2b2e73ad262aad2')
# Add missing dependencies if needed
[[ $_build_voip == true ]] && depends=(${depends[@]} 'speex' 'opencv')
@@ -44,100 +41,31 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- _qmake='qmake-qt4'
-
- #
- # BUILD HERE
- #
- msg "Compiling OpenPGP-SDK..."
- cd openpgpsdk/src
- $_qmake
- make
- cd ../..
-
- msg "Compiling libbitdht..."
- cd libbitdht/src
- $_qmake
- make
- cd ../..
-
- msg "Compiling pegmarkdown..."
- cd supportlibs/pegmarkdown
- $_qmake
- make
- cd ../..
+ # remove unwanted plugins
+ if [[ "$_build_voip" != "true" ]] ; then
+ sed -i '/VOIP \\/d' plugins/plugins.pro
+ fi
+ if [[ "$_build_feedreader" != "true" ]] ; then
+ sed -i '/FeedReader/d' plugins/plugins.pro
+ fi
- msg "Compiling libretroshare..."
+ # call version scripts
cd libretroshare/src
- $_qmake
LANG=C ./version_detail.sh
- make
- cd ../..
-
- msg "Compiling libresapi..."
- cd libresapi/src
- $_qmake
- make
- # i'm not 100% sure if this step is required
- # it will download/update some JavaScript files
- msg "Updating webui files..."
- cd webui
- make
- cd ..
cd ../..
- msg "Compiling retroshare-gui..."
cd retroshare-gui/src
- $_qmake
LANG=C ./version_detail.sh
- make
cd ../..
- if [[ "$_build_voip" == "true" ]] ; then
- msg "Compiling VOIP plugin..."
- cd plugins/VOIP
- $_qmake
- make
- cd ../..
- fi
-
- if [[ "$_build_feedreader" == "true" ]] ; then
- msg "Compiling FeedReader plugin..."
- cd plugins/FeedReader
- $_qmake
- make
- cd ../..
- fi
-
- if [[ "$_build_nogui" == "true" ]]; then
- msg "Compiling retroshare-nogui..."
- cd retroshare-nogui/src
- $_qmake
- make
- cd ../..
- fi
+ qmake-qt4 CONFIG=release PREFIX='/usr' LIB_DIR='/usr/lib' RetroShare.pro
+ make
}
package() {
cd "${srcdir}/${_pkgname}"
- # Binaries
- install -D -m 755 \
- retroshare-gui/src/RetroShare06 \
- "$pkgdir/usr/bin/retroshare"
- if [[ "$_build_nogui" == "true" ]]; then
- install -D -m 755 \
- "retroshare-nogui/src/RetroShare06-nogui" \
- "${pkgdir}/usr/bin/retroshare-nogui"
- fi
-
- # Webui files
- install -d -m 655 "${pkgdir}/usr/share/RetroShare06/webui/"
- for _file in $(ls libresapi/src/webfiles/); do
- install -D -m 644 \
- "libresapi/src/webfiles/${_file}" \
- "${pkgdir}/usr/share/RetroShare06/webui/"
- done
+ make INSTALL_ROOT="${pkgdir}" install
# Plugins
if [[ "$_build_voip" == "true" ]] ; then
@@ -150,31 +78,4 @@ package() {
"plugins/FeedReader/libFeedReader.so" \
"${pkgdir}/usr/lib/retroshare/extensions6/libFeedReader.so"
fi
-
- # Applications menu entry
- mkdir -p "$pkgdir/usr/share/applications"
- cat >"$pkgdir/usr/share/applications/retroshare.desktop" <<EOF
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=RetroShare
-GenericName=Sharing Network
-Comment=Secure communication with your friends
-Icon=/usr/share/pixmaps/retroshare_blue.png
-Exec=/usr/bin/retroshare
-Terminal=false
-StartupNotify=true
-Categories=Network;InstantMessaging;FileTransfer;Chat;Email;
-EOF
- install -D -m 644 \
- "retroshare-gui/src/gui/images/logo/logo_512.png" \
- "${pkgdir}/usr/share/pixmaps/retroshare_blue.png"
-
- # bdboot (needed to bootstrap the DHT)
- install -D -m 644 \
- "libbitdht/src/bitdht/bdboot.txt" \
- "${pkgdir}/usr/share/RetroShare06/bdboot.txt"
-
- # Skins
- cp -r "retroshare-gui/src/qss" "${pkgdir}/usr/share/RetroShare06/"
}
diff --git a/retroshare.install b/retroshare.install
index 612e08c624a3..0b8bbbdea6d8 100644
--- a/retroshare.install
+++ b/retroshare.install
@@ -1,14 +1,28 @@
-post_install() {
+upd_db() {
if [[ -x update-desktop-database ]]; then
echo "Update desktop database..."
update-desktop-database -q
fi
}
+post_install() {
+ xdg-icon-resource install --size 24 /usr/share/icons/hicolor/24x24/apps/retroshare06.png application-RetroShare06
+ xdg-icon-resource install --size 48 /usr/share/icons/hicolor/48x48/apps/retroshare06.png application-RetroShare06
+ xdg-icon-resource install --size 64 /usr/share/icons/hicolor/64x64/apps/retroshare06.png application-RetroShare06
+ xdg-icon-resource install --size 128 /usr/share/icons/hicolor/128x128/apps/retroshare06.png application-RetroShare06
+
+ upd_db
+}
+
post_upgrade() {
post_install
}
post_remove() {
- post_install
+ xdg-icon-resource uninstall --size 24 /usr/share/icons/hicolor/24x24/apps/retroshare06.png
+ xdg-icon-resource uninstall --size 48 /usr/share/icons/hicolor/48x48/apps/retroshare06.png
+ xdg-icon-resource uninstall --size 64 /usr/share/icons/hicolor/64x64/apps/retroshare06.png
+ xdg-icon-resource uninstall --size 128 /usr/share/icons/hicolor/128x128/apps/retroshare06.png
+
+ upd_db
}