summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdomlop2018-09-05 07:42:35 +0200
committermdomlop2018-09-05 07:42:35 +0200
commit11d467ff68a459da630b5e32ad4cd074dafc3639 (patch)
tree5919b9fa5b208d1a4b0905753c5ee60a704f0c14
downloadaur-11d467ff68a459da630b5e32ad4cd074dafc3639.tar.gz
First beta release
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d1fbe346acc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = retrosmart-qtcurve-theme
+ pkgdesc = Retrosmart theme for QtCurve.
+ pkgver = 1.0b
+ pkgrel = 1
+ url = https://github.com/mdomlop/retrosmart-qtcurve-theme.git
+ arch = any
+ license = GPL3
+ optdepends = qtcurve-qt4: Qt4
+ optdepends = qtcurve-qt5: Qt5
+ optdepends = qtcurve-kde: Qt5 (with KDE integration)
+ optdepends = qtcurve-gtk2: Gtk2
+ optdepends = retrosmart-aurorae-themes: The corresponding Aurorae themes
+ optdepends = retrosmart-icon-theme: The corresponding icon theme
+ optdepends = retrosmart-gtk-themes: The corresponding GTK themes
+ optdepends = retrosmart-openbox-themes: The corresponding Openbox themes
+ optdepends = retrosmart-wallpapers: The corresponding backgrounds project
+ optdepends = retrosmart-x11-cursors: The corresponding X11 cursor theme
+ optdepends = retrosmart-xfwm4-themes: The corresponding XFwm4 themes
+ optdepends = retrosmart-kvantum-theme: The corresponding theme for Kvantum
+ source = https://github.com/mdomlop/retrosmart-qtcurve-theme/archive/1.0b.tar.gz
+ md5sums = eb12d5eaa4707ddb08ce3b40f2c9458e
+
+pkgname = retrosmart-qtcurve-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15343f54bdce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Manuel Domínguez López <mdomlop at gmail dot com>
+
+_pkgver_year=2018
+_pkgver_month=09
+_pkgver_day=05
+
+pkgname=retrosmart-qtcurve-theme
+pkgver=1.0b
+pkgrel=1
+pkgdesc="Retrosmart theme for QtCurve."
+
+url="https://github.com/mdomlop/$pkgname.git"
+source=("https://github.com/mdomlop/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('eb12d5eaa4707ddb08ce3b40f2c9458e')
+
+license=('GPL3')
+
+optdepends=('qtcurve-qt4: Qt4'
+ 'qtcurve-qt5: Qt5'
+ 'qtcurve-kde: Qt5 (with KDE integration)'
+ 'qtcurve-gtk2: Gtk2'
+ 'retrosmart-aurorae-themes: The corresponding Aurorae themes'
+ 'retrosmart-icon-theme: The corresponding icon theme'
+ 'retrosmart-gtk-themes: The corresponding GTK themes'
+ 'retrosmart-openbox-themes: The corresponding Openbox themes'
+ 'retrosmart-wallpapers: The corresponding backgrounds project'
+ 'retrosmart-x11-cursors: The corresponding X11 cursor theme'
+ 'retrosmart-xfwm4-themes: The corresponding XFwm4 themes'
+ 'retrosmart-kvantum-theme: The corresponding theme for Kvantum')
+
+arch=('any')
+group=('retrosmart')
+
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+ }
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make install DESTDIR=$pkgdir
+}