summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Choffet2017-03-10 17:05:32 -0500
committerPierre Choffet2017-03-10 17:05:32 -0500
commit48eda850bc950776dbbf61d4f47c45033c9a18ea (patch)
tree2c1ec26cca824f643e6d0363735c7cc79a5075f4
downloadaur-48eda850bc950776dbbf61d4f47c45033c9a18ea.tar.gz
Working package
-rw-r--r--.SRCINFO29
-rw-r--r--ChangeLog3
-rw-r--r--PKGBUILD57
-rw-r--r--return-to-the-roots.install3
-rwxr-xr-xrttr.sh3
5 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3e89bbc205d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Fri Mar 10 22:04:38 UTC 2017
+pkgbase = return-to-the-roots
+ pkgdesc = Free/libre implementation of The Settlers II game engine
+ pkgver = 0.8.1.r3017.bf9fcc60
+ pkgrel = 1
+ url = https://siedler25.org/
+ install = return-to-the-roots.install
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = boost
+ makedepends = sdl_mixer
+ makedepends = curl
+ makedepends = lua
+ makedepends = miniupnpc
+ conflicts = s25rttr
+ conflicts = s25rttr-nightly-bin
+ source = git+https://github.com/Return-To-The-Roots/s25client.git
+ source = rttr.sh
+ source = return-to-the-roots.install
+ sha256sums = SKIP
+ sha256sums = ac414690d648019dab24a21b4d240acc99a0f2473f6a3144a5c827559fedad3b
+ sha256sums = 98ff574f201c6b6a7142c497b33471db8967418ecd245361673be3187c44ae5b
+
+pkgname = return-to-the-roots
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..d3d990d007ad
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,3 @@
+2017-03-10 Pierre Choffet <peuc@wanadoo.fr>
+ * 0.8.1.r3017.bf9fcc60 :
+ Initial PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1afa13128492
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Pierre Choffet <peuc@wanadoo.fr>
+
+pkgname=return-to-the-roots
+pkgver=0.8.1.r3017.bf9fcc60
+pkgrel=1
+pkgdesc="Free/libre implementation of The Settlers II game engine"
+arch=("i686" "x86_64")
+url="https://siedler25.org/"
+license=("GPL3")
+makedepends=("git" "boost" "sdl_mixer" "curl" "lua" "miniupnpc")
+depends=("")
+conflicts=("s25rttr" "s25rttr-nightly-bin")
+install="return-to-the-roots.install"
+changelog="ChangeLog"
+source=("git+https://github.com/Return-To-The-Roots/s25client.git" "rttr.sh" "return-to-the-roots.install")
+sha256sums=('SKIP' "ac414690d648019dab24a21b4d240acc99a0f2473f6a3144a5c827559fedad3b" "98ff574f201c6b6a7142c497b33471db8967418ecd245361673be3187c44ae5b")
+
+pkgver() {
+ cd "s25client/"
+ echo "0.8.1.r$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+prepare() {
+ cd "s25client/"
+
+ # Get modules
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "s25client/build/"
+
+ ./cmake.sh --prefix="$pkgdir/usr" --RTTR_BINDIR="bin" --RTTR_DATADIR="share/s25rttr" --RTTR_LIBDIR="lib/s25rttr"
+ make
+}
+
+package() {
+ cd "s25client/build"
+
+ # Use make based installer
+ make install
+
+ # Copy launch script
+ mv "$srcdir/rttr.sh" "$pkgdir/usr/bin/"
+
+ # Get additional files
+ mkdir -p $pkgdir/usr/share/applications
+ cp "$srcdir/s25client/debian/s25rttr.desktop" "$pkgdir/usr/share/applications/"
+
+ mkdir -p $pkgdir/usr/share/pixmaps
+ cp "$srcdir/s25client/debian/s25rttr.png" "$pkgdir/usr/share/pixmaps/"
+
+ # Tweak directories
+ cd "$pkgdir/usr"
+ mv lib64/driver/ lib/
+ rmdir lib64
+}
diff --git a/return-to-the-roots.install b/return-to-the-roots.install
new file mode 100644
index 000000000000..5d19bbf8b069
--- /dev/null
+++ b/return-to-the-roots.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo " Put your original Settlers 2 DATA and GFX folders in /usr/share/s25rttr/S2/"
+}
diff --git a/rttr.sh b/rttr.sh
new file mode 100755
index 000000000000..d6145cf436f7
--- /dev/null
+++ b/rttr.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+cd /usr && LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib/s25rttr/" bin/s25client