summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Choffet2017-03-10 18:01:12 -0500
committerPierre Choffet2017-03-10 18:01:12 -0500
commit4e63a02a8448f28a656c28d71b86fbfd3e9b4133 (patch)
tree1c5039adf9500d113419859c939a02e25c3ecc81
parent48eda850bc950776dbbf61d4f47c45033c9a18ea (diff)
downloadaur-4e63a02a8448f28a656c28d71b86fbfd3e9b4133.tar.gz
Fix build
-rw-r--r--ChangeLog7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index d3d990d007ad..b946bcd45c6e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
2017-03-10 Pierre Choffet <peuc@wanadoo.fr>
- * 0.8.1.r3017.bf9fcc60 :
+ * 0.8.1.r3017.bf9fcc60-2 :
+ Fix return-to-the-roots.install sha256sums value
+ Add missing build dependencies
+ Add missing run dependencies
+
+ * 0.8.1.r3017.bf9fcc60-1 :
Initial PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 1afa13128492..7d977c8a3b62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=return-to-the-roots
pkgver=0.8.1.r3017.bf9fcc60
-pkgrel=1
+pkgrel=2
pkgdesc="Free/libre implementation of The Settlers II game engine"
arch=("i686" "x86_64")
url="https://siedler25.org/"
license=("GPL3")
-makedepends=("git" "boost" "sdl_mixer" "curl" "lua" "miniupnpc")
-depends=("")
+makedepends=("cmake" "git" "boost" "sdl_mixer" "curl" "lua" "miniupnpc")
+depends=("sdl_mixer" "miniupnpc")
conflicts=("s25rttr" "s25rttr-nightly-bin")
install="return-to-the-roots.install"
changelog="ChangeLog"
source=("git+https://github.com/Return-To-The-Roots/s25client.git" "rttr.sh" "return-to-the-roots.install")
-sha256sums=('SKIP' "ac414690d648019dab24a21b4d240acc99a0f2473f6a3144a5c827559fedad3b" "98ff574f201c6b6a7142c497b33471db8967418ecd245361673be3187c44ae5b")
+sha256sums=('SKIP' "ac414690d648019dab24a21b4d240acc99a0f2473f6a3144a5c827559fedad3b" "edb41253442928a2313f856021c06f6d2999b780f0426c05cd7bdb2381a627ea")
pkgver() {
cd "s25client/"
@@ -49,9 +49,4 @@ package() {
mkdir -p $pkgdir/usr/share/pixmaps
cp "$srcdir/s25client/debian/s25rttr.png" "$pkgdir/usr/share/pixmaps/"
-
- # Tweak directories
- cd "$pkgdir/usr"
- mv lib64/driver/ lib/
- rmdir lib64
}