summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Choffet2020-08-12 15:29:17 -0400
committerPierre Choffet2020-08-12 15:40:26 -0400
commit69216c5aadf67c40b6d035451495fc7d725089a4 (patch)
treeb970f9eb8a4947f4a4304176077d0eaf6793fe6f
parentc50d81a66df17ee7a0ccd3d739734227eb03a475 (diff)
downloadaur-69216c5aadf67c40b6d035451495fc7d725089a4.tar.gz
Update PKGBUILD after upstream changes
-rw-r--r--.SRCINFO8
-rw-r--r--ChangeLog6
-rw-r--r--PKGBUILD22
3 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6b1bb21bb4b..efd255062183 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = return-to-the-roots-git
pkgdesc = Free/libre implementation of The Settlers II game engine
- pkgver = r4467.3af7f7c76
+ pkgver = r4685.b153c4897
pkgrel = 1
url = https://siedler25.org/
install = return-to-the-roots.install
@@ -13,14 +13,14 @@ pkgbase = return-to-the-roots-git
makedepends = mesa
makedepends = sdl_mixer
makedepends = curl
- makedepends = lua52
+ makedepends = lua53
makedepends = miniupnpc
makedepends = libsamplerate
depends = boost-libs
depends = libgl
depends = sdl_mixer
depends = miniupnpc
- depends = lua52
+ depends = lua53
depends = libsamplerate
optdepends = siedler2-data
provides = return-to-the-roots
@@ -39,6 +39,7 @@ pkgbase = return-to-the-roots-git
source = git+https://github.com/Return-To-The-Roots/s25edit.git
source = git+https://github.com/Return-To-The-Roots/s25update.git
source = git+https://github.com/Return-To-The-Roots/version.git
+ source = git+https://github.com/mat007/turtle.git
source = rttr.sh
source = return-to-the-roots.install
sha256sums = SKIP
@@ -53,6 +54,7 @@ pkgbase = return-to-the-roots-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = b623d74292ca332b65290f15adb0c41994a80eb4f5d247c713a0d43775f9e8f8
sha256sums = 888a1cd55350971ec3660de79c82760be63ed40617e8ef6931c20b07bc73e1a9
diff --git a/ChangeLog b/ChangeLog
index 334ab05d16c5..cbe5d7fb9ac1 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
+2020-08-12 Pierre Choffet <peuc@wanadoo.fr>
+ * r4685.b153c4897-1 :
+ Update build after upstream changes
+
2019-10-17 Pierre Choffet <peuc@wanadoo.fr>
- * r4467.3af7f7c76 :
+ * r4467.3af7f7c76-1 :
Force build to use system libsamplerate
2019-05-02 Pierre Choffet <peuc@wanadoo.fr>
diff --git a/PKGBUILD b/PKGBUILD
index dcb8c2c6ea7d..ed85294c97ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Pierre Choffet <peuc@wanadoo.fr>
pkgname=return-to-the-roots-git
-pkgver=r4467.3af7f7c76
+pkgver=r4685.b153c4897
pkgrel=1
pkgdesc="Free/libre implementation of The Settlers II game engine"
arch=("x86_64")
url="https://siedler25.org/"
license=("GPL3")
-makedepends=("cmake" "git" "boost" "mesa" "sdl_mixer" "curl" "lua52" "miniupnpc" "libsamplerate")
-depends=("boost-libs" "libgl" "sdl_mixer" "miniupnpc" "lua52" "libsamplerate")
+makedepends=("cmake" "git" "boost" "mesa" "sdl_mixer" "curl" "lua53" "miniupnpc" "libsamplerate")
+depends=("boost-libs" "libgl" "sdl_mixer" "miniupnpc" "lua53" "libsamplerate")
optdepends=("siedler2-data")
conflicts=("return-to-the-roots" "s25rttr" "s25rttr-nightly-bin")
provides=("return-to-the-roots")
@@ -26,6 +26,7 @@ source=("git+https://github.com/Return-To-The-Roots/s25client.git"
"git+https://github.com/Return-To-The-Roots/s25edit.git"
"git+https://github.com/Return-To-The-Roots/s25update.git"
"git+https://github.com/Return-To-The-Roots/version.git"
+ "git+https://github.com/mat007/turtle.git"
"rttr.sh" "return-to-the-roots.install")
sha256sums=("SKIP"
"SKIP"
@@ -39,6 +40,7 @@ sha256sums=("SKIP"
"SKIP"
"SKIP"
"SKIP"
+ "SKIP"
"b623d74292ca332b65290f15adb0c41994a80eb4f5d247c713a0d43775f9e8f8"
"888a1cd55350971ec3660de79c82760be63ed40617e8ef6931c20b07bc73e1a9")
@@ -62,6 +64,7 @@ prepare() {
git config submodule.s25edit.url $srcdir/s25edit
git config submodule.s25update.url $srcdir/s25update
git config submodule.version.url $srcdir/version
+ git config submodule.contrib/turtle.url $srcdir/turtle
# Get modules
git submodule update
@@ -70,15 +73,18 @@ prepare() {
build() {
cd s25client
- # Force use of system LUA library
- sed -i 's/set(_contrib_lua_libpath ${_contrib_lua_path}\/lin64)/set(_contrib_lua_libpath \/usr\/lib\/)/' libs/libGamedata/CMakeLists.txt
-
# Build
mkdir -p build && cd build
+
+ # NOTE: Wno-error=stringop-overflow is added to bypass an error in
+ # 25client/libs/s25main/GamePlayer.cpp:328
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
- -DBUILD_TESTING=Off -RTTR_BINDIR="bin" -DRTTR_DATADIR="share/s25rttr" \
+ -DBUILD_TESTING=Off \
+ -DCMAKE_CXX_FLAGS="-Wno-error=stringop-overflow" \
+ -RTTR_BINDIR="bin" -DRTTR_DATADIR="share/s25rttr" \
-DRTTR_LIBDIR="lib/s25rttr" -DRTTR_EXTRA_BINDIR="bin" \
- -DRTTR_USE_SYSTEM_SAMPLERATE=On ..
+ -DRTTR_USE_SYSTEM_SAMPLERATE=On \
+ -DLUA_INCLUDE_DIR=/usr/include/lua5.3/ ..
make
}